iPhone Couple of Safari problems, not sure if JB related

Discussion in 'Jailbreaks and iOS Hacks' started by Qaanol, Mar 16, 2013.

  1. Qaanol macrumors 6502a

    Joined:
    Jun 21, 2010
    #1
    I'm seeing two odd behaviors in Safari, and I'm wondering if there's a simple way to fix them.

    First, when I search Google from the dedicated search box in Safari, the links on the results page are unresponsive. When I tap one of them, it flashes as if clicked, but nothing else happens: the site does not load, and I remain on the search results page.

    However, if I hold down on one of the links, the menu pops up and from there the "Open" and "Open in background" buttons work correctly. Interestingly, if I type into the search box within Google, the results page works fine. It is only when I use the Safari search box that this issue occurs, and it happens every time.

    Second, when I reopen Safari after a having it closed for a while, the page that's open will sometimes not let me zoom until I refresh it. The page will work normally in other ways, such as scrolling and letting me open links, but it won't zoom.

    If I navigate to another page, then hit the Back button, the issue is still there: it only manifests on the pages that were current at the time I reopened Safari. Refreshing the page enables zoom again.

    I have a number of Safari-related tweaks:
    Bookmarks+ for Safari
    FullScreen for Safari
    GridTab for Safari
    PDF Printer for Safari
    Safari Download Enabler
    Tab+
    WebScrollian

    Plus a whole bunch of other tweaks.

    Has anyone else experienced these issues? Know how to correct them?
     
  2. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
  3. Qaanol thread starter macrumors 6502a

    Joined:
    Jun 21, 2010
    #3
    iPhone 4S on iOS 6.1.2

    And a third problem that's been intermittent: occasionally when Safari loads a page, it won't let me scroll all the way to the bottom. It will "bounce back" as if at the bottom, when there is still more of the page below. Rotating the phone orientation fixes the problem.
     
  4. BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #4
    The first problem you mentioned about links being unresponsive and only working if you tap and hold, I experienced the same exact thing on my iPhone. I'm on a 4S on 6.1.2 but I experienced it on 6.1 and 6.1.1 as well.

    I think its Fullscreen for safari. Either that tweak has a bug, or it doesn't play well with WebScrollian. I named these 2 tweaks because those are the only 2 safari tweaks I've used on my device. I have since removed Fullscreen for safari and I haven't had that problem since. So it's either Fullscreen for Safari that has a bug, or it doesn't play well with WebScrollian. I don't think it is the other tweaks because I don't use any of them yet I recently experienced the same problem of links not working after tapping them.

    Edit: I bet if you remove Fullscreen for Safari most if not all of throes problems will go away. Fullscreen by itself is a solid tweak, but I don't think it plays nice with all the other safari tweaks.

    I've heard fantastic things about r_plus's safari tweak Sleipnizer. r_plus makes some of my favorite tweaks. He also offers a lite version. Maybe you could try removing Fullscreen for Safari and give Sleipnizer a shot? It might be more stable with all the other safari tweaks you have installed. Personally, I just use WebScrollian nowadays. That's all I need lol
     
  5. Qaanol thread starter macrumors 6502a

    Joined:
    Jun 21, 2010
    #5
    Thanks for the detailed response.

    I just tried removing both FullScreen and WebScrollian: no change, even after clearing Safari data and restarting the phone.

    I also had these problems, at least the Google links not working, on 6.1 and 6.1.1. When I upgraded to 6.1.2 I recall having the issue persist even when I was not jailbroken (I had restored from my backup though.)

    It might be relevant that I am using a modified User Agent string, which I put in place back when I was on 5.0.1, by modifying a plist.

    Does anyone know what the default User Agent string is for Safari on iOS 6.1.2 (preferably from an iPhone 4S)?
     
  6. BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #6
    Ahhh ok I see. Where is the file located? Also, how did you manually edit the string? I'd like to do that to my phone instead of using an MS Addon. If you don't remember that's fine. I can just google it. Thanks. Good luck.
     
  7. Mike1770 macrumors newbie

    Joined:
    Apr 4, 2013
    #7
    Don't know if anyone can help, I have a jail broken 4s on 6.2.1 an I tried to download an app from cydia it wasent working so I switch off the phone now it takes the phone about an hour to load and safari my email and cydia won't open can someone please help me? Thanks
     
  8. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #8
    Uninstall that app. Boot up holding the volume up button and you should now be in safe mode and can access cydia
     
  9. Mrg02d macrumors 65816

    Joined:
    Jan 27, 2012
    #9
    I've also got this problem with links. Seems to happen if I do a safari search from the spotlight page.
     

Share This Page