Crash...unmountable HD...help please

mondotrasho

macrumors newbie
Original poster
Jun 2, 2002
2
0
I have a powerbook G3, that was running OS9. Yesterday, my computer crashed, and upon startup could no longer read the hard drive. I have run disk first aid, but it is not able to mount the HD, and can't complete repairs. What can I do to remedy my situation without needing to initialize my HD? Any info would be appreciated.
thanks.
 

Falleron

macrumors 68000
Nov 22, 2001
1,609
0
UK
If you have a Norton Disc then you can boot off that + use disk doctor to repair the damage. Thats the only program that I have used to fix the problem. I think there is another one called TechTools Pro that will do the same job.
 

AmbitiousLemon

Moderator emeritus
Nov 28, 2001
3,338
0
down in Fraggle Rock
fallerons got the right idea so i wont reiterate. but i do want top mention that you mau need to run disk doctor or tech tool's multi scanner several times before all the errors are fixed. just run it until it finds nothing wrong.
 

spuncan

macrumors 6502
Jul 18, 2001
287
0
Detroit
happened to us once but that was cuz I tried to install a corrupt copy of OSX Server :D In the end we lost the data and gave up. the hd is still at apple but we gave up pretty much.
 

AlphaTech

macrumors 601
Oct 4, 2001
4,556
0
Natick, MA
I repaired a system with a similar issue last night. DiskWarrior 2 found the drive and was able to repair the damaged directories, even though the drive did not show up on boot. After that TechTool Pro 3.x fixed several things, and Norton repaired the rest. After that, everything worked properly. I also ran the software update control panel, and updated pretty much everything it found (the owner doesn't have an iPod, so no point in updating that).

It was a good thing that the problem happened over the weekend, since the owner works from home two days a week. If this had happened on either of those days, she would have been in a worse place.

I did work for her about a year ago, updating the OS as well as increasing the RAM inside the computer and running all the utilities on the system. In case you are wondering, it's a G3 350MHz Blue and White with the original 6GB hard drive and now has 640MB of RAM. I installed both OS 9.2.1 back when I had it last year, as well as OS X 10.1. Last night I updated it to 9.2.2 and 10.1.4.
 

awulf

macrumors 6502
Mar 1, 2002
483
1
South Australia
Originally posted by spuncan
happened to us once but that was cuz I tried to install a corrupt copy of OSX Server :D In the end we lost the data and gave up. the hd is still at apple but we gave up pretty much.
I did that. And there was no way I could access my HD, I tried everything (Norton Utilities, Tech Tool Pro 3, FWB HD tool kit, Disk Warrior 2). But I found a way to retrieve all my data and that was with Yellow Dog Linux. I installed YDL 2.1 onto an external HD including HFSPlusUtils (which mounts HFS+ partitions under Linux) and I could see all my files. But this Program is hard to use so I tried installing Kio-mac under linux but that doesn't seem to work so I am still triyng to recover all my data. I am currently downloading YDL 2.2 and I will see if Kio-Mac will work properly under that. (Also Mac-On-Linux can also boot the Mac os on the Hard Disk but MOL also doesn't seem to work on my computer (PM7600) umder YDL 2.1. If YDL 2.2 still won't work ill try downloading SuSE or LinuxPPC.

If there is a Mac OS way of fixing this problem pease tell me:( !!! Because I still haven't recovered all the data because under HFS+Utils you can't copy entire folders.