D-Link USb Wireless

Discussion in 'General Mac Discussion' started by Jdawg19, Nov 24, 2003.

  1. Jdawg19 macrumors newbie

    Nov 24, 2003
    Has anyone got a D-Link DWL-122 USB wireless adaptor to run under Panther without freezing the machine or losing network connectivity? I'm running it on a PB G3 333. I have the newest drivers from D-Link but they only support Jaguar. I was wondring if anyone had a workaround or a hack. Thanks,
  2. brhmac macrumors regular

    Apr 21, 2003
    Planet Earth
    Similar problems


    I had the same problems you're reporting, though I'm running OS 10.2.8 on my PowerBook G3 (300 MHz).

    Not only did the adaptor lockup my computer -- something I had not seen my computer do since I installed OS X -- but the adaptor would act as though it were "offline," though the system preference screen indicated a solid connection.

    D-Link technical support was helpful enough -- and more than condescending enough -- but it didn't help. In the end, I returned the adaptor.

    Still looking for another solution. I hear the Belkin gear is solid, but I don't know the model numbers. Hopefully, someone that responds to this thread can pass along the info.

    Best of luck with a solution.
  3. Jdawg19 thread starter macrumors newbie

    Nov 24, 2003
    Looks like I'm gonna end up donating the USB adapter to my girlfriends PC, and get myself something else. Thanks for the reply.
  4. question fear macrumors 68020

    question fear

    Apr 10, 2003
    The "Garden" state
    i tried using that dlink usb adaptor on my bro's windows ME pc.
    installing it triggered a corrupted file that took my dad and me two days to fix...
    it works now, but it was a heart stopping restart when we finally tried it (after doing some major work on fixing his files.)
    so it could be their driver, somehting bads goin down.
  5. aldo macrumors regular

    Oct 26, 2003
    England, UK
    Please don't buy Belkin stuff. Belkin is a sinking ship and they are unloading their remaining stock as fast as possible.

    If you didn't hear, quite recently they cut the price of their routers down to like $20 (these are wifi ones)... and the only hidden suprise is that every 10 webpages it routes it reroutes it to a nice page of adverts for you.

    They don't actually manufacture stuff themselves - most of their stuff is just rebranded netgear, linksys and d-link gear.

    If you can, get Netgear, linksys or D-Link. If at all possible, you might want to save yourself some $$$ by getting the 'extra value 'stuff from OEM manufacturers who usually buy overstock etc from the big 3.
  6. MacPulse Zack macrumors newbie

    Dec 12, 2002
    Jacksonville, FL
    I too have experienced the same problem with the DWL-122 on a Grape iMac 333Mhz running Panther 10.3.2.

    Not only does it lockup the machine totally, but it seems the drop in network connectivity only occurs when you try to upload a file of substantial size, either as an email attachement, an ftp upload or a kdx upload.

    Does it work anybetter under Jaguar 10.2.8? I may revert so that I can get connectivity. This iMac's ethernet port is dead, so USB-based ethernet or wireless is the only option.

    Does anyone know of any other USB-based wireless or wired network adapters that work well with Panther?

  7. hexstar macrumors member

    Aug 28, 2004
    I've experienced the same problems as you, I'm using MacOS X 10.3.5...ironically earlier this summer at a computer camp I was at, half of one of their labs were not able to use the network/internet because the router kept stop working, guess what company made it, D-Link...something tells me they don't know how to make network equipment and never will, D-Link = Don't-Link :mad: - made a post about my experience with this device here already: http://www.daniweb.com/techtalkforums/thread9957.html - MacPulse Zack, check out this USB wireless adapter: http://macwireless.com/html/products/11g_11b_cards/11bUSB.html
  8. mklos macrumors 68000


    Dec 4, 2002
    My house!
    I had the same problems with my dad's 333 MHz G3 iMac and I just repaired permissions and I didn't have any problems after that. There were a whole bunch of things that it repaired too.
  9. BFedrec macrumors newbie

    Feb 20, 2004
    Lawrenceville, GA
    I've had the same locking up problem on my iBook G4... the tech support wasn't helpful at all for me, they said if you're not running 10.3.2 they won't support it... and as I've got the updates/patches installed I'm running 10.3.6 or 7 I think. I'm in the "donating it to a PC" camp now... going to put it on an old machine in my 7 year-old son's room, and hope to find a good deal on an airport card. :(
  10. MacPulse Zack macrumors newbie

    Dec 12, 2002
    Jacksonville, FL
    The D-Link unit is a horrible, worthless product on the Mac. It works fine on PC. I've since tried two other units and spent countless hours via email and phone with D-Link support and the units are simply lemons. Apparenly this is one product they can't write a good driver for.

    Note of caution: Stay away from the D-Link USB wireless adapter for Macs!

Share This Page