Damaged iPhoto Directory?

Discussion in 'Mac Apps and Mac App Store' started by acox, Sep 23, 2004.

  1. acox macrumors newbie

    Sep 23, 2004
    Any thoughts on how to fix my boneheaded move are greatly appreciated. I accidentaly deleted photos out of my iPhoto library instead of doing it through the application. After a relaunch of iPhoto, they apprered as white squares in the main album, but I couldn't move those squares to the trash. I then moved out all of the data files from the folder "iPhoto" and relaunched the app, thinking that it would regenerate the proper data files without the weird artifacts of the improperly deleted photos. But after opening, it said there were no photos in my library and all of the albums i had said (0) photos. I put the old data files back and relaunched, but the problem persists. Any ideas on how to fix this? All the pics are stil there in the directory structure iPhoto put them in, with their corresponding data, but iPhoto doesn't see them. Bad times.
  2. jeremy.king macrumors 603


    Jul 23, 2002
    Fuquay Varina, NC
    This is weird...I just tried dragging a pic to the trash and nothing happened....BUT, highliting the pic and hitting Command + Delete works. :confused: Try this with your white box pics.
  3. Mechcozmo macrumors 603


    Jul 17, 2004
    Try Command Option Shift. I belive that that is the command to regenerate the iPhoto library. WARNING: Takes a long time if you have a lot of pictures! (Well, on a 6000 pictures and a 867 Quicksilver it took about 5 minutes.)
  4. Abstract macrumors Penryn


    Dec 27, 2002
    Location Location Location
    Well this is weird. My iPhoto started acting strangely as well. I tried renaming a few of my folders in Finder so that I know what event each date corresponds to (some of us can't remember the exact date of every event of our lives....).

    However, now a white square is where the photo's used to be. I tried deleting the photos with Delete and Cmd+Delete, but nothing. A white square the size of all the other thumbnails is left behind. I've even tried changing the folder names back and putting the photos back into iPhoto, but I get an error.

    Like many people, I really don't like the default and only way iPhoto handles files. They won't even let me change it to a date + name scheme rather than just a date scheme. :mad:

Share This Page