Desktop icons moved to top of screen and web pages to bottom?

Discussion in 'MacBook' started by annieburman, Apr 9, 2013.

  1. annieburman macrumors newbie

    Joined:
    Apr 9, 2013
    #1
    Hi. I start using my laptop today and, although my screensaver is in the correct place (full screen), all my desktop icons have moved to the top of the screen (and above where I cannot access them) and open webpages to the bottom (there maybe others I cannot see to access). Even after logging off and on again it's the same. What can I do please?
    Using 10.7.5 on a 2007 MacBook
    Thanks.
     
  2. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #2
    Seems like your screen resolution is set wrong, if so Open displays in System Preferences and set it to the right one.
     
  3. annieburman, Apr 16, 2013
    Last edited: Apr 16, 2013

    annieburman thread starter macrumors newbie

    Joined:
    Apr 9, 2013
    #3
    Desktop icons moved to top of screen and above


    Hi. I tried this, all of the screen resolutions, and it made no difference. I've attached a screenshot. Note that the new screenshot appeared in the right place on the screen but you'll see all the others at the top and can't see ay others.
     

    Attached Files:

  4. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #4
    Delete the "com.apple.desktop.plist" inside your Home/Library Folder and the .DS_Store file on the desktop, relaunch Finder and see if that solved the problem.

    You could also make a new User Account in Users & Groups, login into that Account and see what happens there, if the issue does not arise there you know it is your normal User Account which is affected.

    Edit: Or, this might be the easiest solution, copy/move all the files in a new Folder created in Documents, name it whatever you like, then move them back to the Desktop.
     
  5. annieburman thread starter macrumors newbie

    Joined:
    Apr 9, 2013
    #5
    Icons moved to top of screen and above



    Thank you. I've looked on my laptop (Macbook 2007 with 10.7.5) and cannot find either of those files anywhere. I guess I'll have to try your other options.
     
  6. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #6
    If it isn't solved yet here is the way to find the files.
    First let me tell you I/We don't know how advanced the User on the other side is so I did not say where those files are.

    The com.apple.desktop.plist is in your preferences Folder inside your Library Folder, It is invisible by Default on Mountain Lion and I think also on Lion.
    The .DS_Store is also invisible and is in the Desktop Folder.

    Now, the easiest way to delete these files is with Terminal, I could tell you how to make the Library Folder visible but that also must be done in Terminal and it still leaves the file on the Desktop alone so here is the Terminal way.

    In the explanation below you have to replace the **** with your User Home folder name.

    1. Open Terminal
    2. Enter the following text:
    sudo rm /Users/****/Library/Preferences/com.apple.desktop.plist
    3. Hit Enter
    4. Enter Password
    5. sudo rm /Users/****/Desktop/.DS_Store
    6. Hit Enter
    7. You might need to enter password again but most likely not.
    8. killall Finder
    (Finder with capital F otherwise Finder won't relaunch)

    That's it

    The Finders preferences are now reset and you have to redo them.

    Now, hopefully this will solve the problem.
    I will tell you a few more things you can do with Terminal like how to make the Library Folders visible.

    1. sudo chflags nohidden /Library
    (Makes your main Library visible)
    2. sudo chflags nohidden /Users/****/Library
    (Makes your Home Folder Library visible-****= your Home Folders User Name)
    3. defaults write com.apple.finder AppleShowAllFiles True
    (Makes files visible)
    defaults write com.apple.finder AppleShowAllFiles False
    (Makes them invisible again)
     

Share This Page