Disabling automatic mic switching


macrumors newbie
Original poster
May 19, 2013
I have a mid-2012 15" MBP with OSX version 10.8.3. While using Skype I sometimes need to use headphones and the ones I normally have handy are earbuds with an integrated microphone. I would prefer to use the internal mic on the MBP, however when the earbuds are plugged in the earbud mic becomes the internal mic as opposed to being identified as external and OSX does not give an option to select different sources.

Soundflower does not have this option either. A forum search found only 1 thread in 2010 addressing this, but it was unresolved with the suggestion of using Rogue Amoeba's LineIn which does not support this feature as far as I can tell.

Any option other than buying another set of earbuds that does not have a built in mic?