Disk Utility says "Couldn’t unmount disk." only in my user account.

Discussion in 'Mac Basics and Help' started by The General, Jan 7, 2012.

  1. The General macrumors 601

    Joined:
    Jul 7, 2006
    #1
    [​IMG]

    I've got a problem that has been causing me a lot of headaches as of late. Essentially, Disk Utility won't partition any disks under my user account. I spent a week swapping out SSDs and hard drives thinking my hardware was either bad or that my SATA controller wasn't compatible with Sandforce based solid state drives.

    Biggest waste of my time ever, because I just thought to try setting up a new user account to see if that made any difference, and my last option was to boot to a fresh Lion install on an external hard drive. Needless to say, in the user account I made Disk Utility works fine. I tried deleting com.apple.DiskUtility, made no difference. Tried a few others that seemed relevant, but nothing seemed to fix it.

    I am at a loss. I mean, I know exactly how to fix it (delete ~/Library and start fresh) but I don't want to have to start over from scratch with all my settings and stuff.

    Any ideas? Anyone run into this before?
     
  2. mphilip1 macrumors newbie

    Joined:
    Mar 7, 2012
    #2
    Had the same problem...

    I have no idea why it's happening, but I had the same problem:
    I had a thumb drive (actually several :)) that were randomly dropping connection or "unable to eject".
    However, creating a new user account seems like it is allowing the drive to mount, allow access and I was finally able to erase it with disk utility.

    We'll see if I'm finally able to make the boot drive for the Linux distro I've been battling with for the last 2 days :)
     

Share This Page