Display port to hdmi no longer shows picture on TV

Discussion in 'MacBook Pro' started by DanMacApple, Apr 2, 2013.

  1. DanMacApple macrumors 6502

    Joined:
    Jul 1, 2010
    #1
    Hi, I have a 2010 MBP with Snow Leopard installed that is no longer sending a video out signal or sound to the TV. I purchased a mini displayport to HDMI adapter which has worked fine for a few years, but now no picture will show on the TV when I connect, just a black screen.

    When I plug in the adapter the MBP monitor does turn blue for a moment so it does recognize that the adapter is plugged in. I try detect displays and nothing else is found.

    I verified the HDMI cable works when not connected to the adapter and I have tried this on several TVs. I have a feeling the adapter is defective, but I wanted to ask if anyone has any suggestions in case there is some fix. Sorry if this has been asked before but I did not find posts when I searched.

    Thanks for your help! Dan
     
  2. Interstella5555 macrumors 603

    Interstella5555

    Joined:
    Jun 30, 2008
    #2
    Probably the adapter has failed, my Moshi one broke after less than 6 months and am already having trouble with the new one. Not sure what the issue is exactly, but that would be my first thought.
     
  3. DanMacApple thread starter macrumors 6502

    Joined:
    Jul 1, 2010
    #3
    Thanks for your input. I think I agree you with you as I will try a new adapter.
     
  4. DanMacApple thread starter macrumors 6502

    Joined:
    Jul 1, 2010
    #4
    If anyone else has any suggestions please let me know as I am purchasing a new adapter but if there are any suggestions on what to do to stop this from happening again that would be helpful. Thanks!
     

Share This Page