Displayport display blank after sleep sometimes in 10.13

Discussion in 'macOS High Sierra (10.13)' started by Soverc, Aug 17, 2017.

  1. Soverc macrumors member

    Joined:
    Oct 7, 2005
    #1
    I am curious if any of you that have had issues in 10.1X with displayport displays not coming back on after sleep (does not happen all the time) have this issue in 10.13 ?
     
  2. HenryAZ macrumors 6502

    HenryAZ

    Joined:
    Jan 9, 2010
    Location:
    South Congress AZ
    #2
    I have had that issue with all newer model Dell displays, using Displayport, not from system sleep, but just from display sleep. And I have tried quite a few of them. NEC and Eizo displays do not exhibit this problem.
     
  3. krogalon, Aug 19, 2017
    Last edited: Aug 22, 2017

    krogalon macrumors newbie

    Joined:
    Aug 11, 2012
    #3
    I'll be able to tell you soon. I just updated my 2012 mac mini to the latest public beta in the hope that the issues will be fixed. I use a Samsung SyncMaster SA850T display, which did not have ANY problems with waking up with MacOS versions prior to 10.12. I even filed a bug about it with apple and provided log files, but they could not reproduce it and closed it. Let's see.

    UPDATE:

    So far my display has woken up from sleep every time!
     
  4. campyguy macrumors 68040

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #4
    Get a VESA-compliant mDP>DP cable from Belkin/Accell/StarTech if you're not using one (subtle hint: most cables aren't compliant).

    Dells don't ship with compliant cables, swapping out the COXOC junk that shipped with the Dells with a compliant cable "fixed" my issues with my 30-odd Dells in my offices - we now use only Accell cables in my offices on displays that don't ship with compliant cables. NEC and Eizo - which are also in my offices - ship with VESA-compliant cables.

    When/if you do get a compliant cable, be sure to reset the display - it will be seen by the PC/Mac as a different device and a new set of Displays overrides will be created for the new cable/display combo.
     
  5. pomme de terre, Nov 23, 2017
    Last edited: Nov 24, 2017

    pomme de terre macrumors newbie

    Joined:
    Dec 1, 2014
    #5
    I just got a Mid 2009? Mini with HS installed. Keyboard strokes does not wake the Dell U2412M display though it wakes the Mini itself with a generic mDP2DP cable. Done the PRAM reset... Unplugged the power cord... Just tried your trick...

    Got a mDP2DVI adapter in the mail and will try that the next week or so.

    There are two "funny" things about this. a/ People with portables seem two have this problem too. b/ I booted the new Mini from a USB SL installation from my old mini and everything worked fine, so if it is the cable then it seem to be an inboard HS compatibility issue and not hardware.

    I will consider your advice getting a VESA mDP2DP if the adapter don't work :)
     

Share This Page