DND Keeps Turning Itself On in iOS 11

Discussion in 'iOS 11' started by robman74, Sep 21, 2017.

  1. robman74 macrumors newbie

    Mar 19, 2010
    Ever since I have updated my phone to iOS 11, Do Not Disturb keeps randomly turning itself on for my iPhone 7 (and as a result on my Apple Watch, too). At first I thought maybe it was because DND While Driving was set to Bluetooth and that when my phone was connecting to Bluetooth devices in my home it would mistakingly think I was in a car. However, I have since turned DND While Driving to Manual and the issue persists.

    I've also checked the DND schedule that I have set (and have had set for as long as that feature was added to iOS) and nothing has changed there. To make sure that wasn't the issue, I turned it off all together and the issue persists at random multiple times throughout the day (which is a major problem for me since I'm a Realtor and am missing calls).

    Anyone else having this issue, or have any ideas how to address this?

    Thank you!
  2. robman74 thread starter macrumors newbie

    Mar 19, 2010
    Bumping this as it still is happening and I’m missain’t all sorts of calls and notifications that are time sensitive. Hoping someone has some thoughts or suggestions.
  3. zaphon macrumors 6502


    Oct 9, 2003
    I use DnD but purely to silence notifications. Calls are still allowed through. I haven't noticed it come on early yet, but I will watch it. For now maybe try disabling it (though good luck sleeping at night if you get a lot of e-mail).
  4. robman74 thread starter macrumors newbie

    Mar 19, 2010
    Letting calls through is a good option for now, thanks for the tip. I just can’t figure out why it keeps turning itself on randomly throughout the day. I really don’t want to do a wipe and clean install.
  5. C DM macrumors Sandy Bridge

    Oct 17, 2011
    You might want to try resetting all settings in case there's some glitch with something somewhere.

Share This Page

4 September 21, 2017