Do you have to be on iOS4 to jailbreak using the new Comex jailbreak?

Marlymarl

macrumors newbie
Original poster
Aug 2, 2010
5
0
what I mean is I am going to have to update from 3.1.2 using itunes to 4.0.1 first right? if so, that will not brick the iphone since its already unlocked and jailbroken?
No, it just jailbreaks your phone. Nothing else...
 

gr8whtd0pe

macrumors 6502a
Feb 21, 2008
515
15
Belle, WV
what I mean is I am going to have to update from 3.1.2 using itunes to 4.0.1 first right? if so, that will not brick the iphone since its already unlocked and jailbroken?
No its for 3.1.2 and up.... Someone already told you that lol.

Wait your phone is already jailbroken? Then why do you want this? It's the same thing.
 

ldobson

macrumors regular
Jun 19, 2009
141
0
Generally I do a full restore to the current version of ios (in my case 3.1.3) then do an upgrade via iTunes to 4.01 and then jailbreak, that will ensure that any previous jailbreak residue is gone. Upgrade two 3GS's this way, one from 3.1.2 and one from 3.1.3, no issues.
 

Marlymarl

macrumors newbie
Original poster
Aug 2, 2010
5
0
I am jailbroken on 3.1.2 still, I have not upgraded to the new firmware. I want to upgrade to the new firmware and keep my unlock

No its for 3.1.2 and up.... Someone already told you that lol.

Wait your phone is already jailbroken? Then why do you want this? It's the same thing.
 

thelatinist

macrumors 603
Aug 15, 2009
5,934
49
Connecticut, USA
I am jailbroken on 3.1.2 still, I have not upgraded to the new firmware. I want to upgrade to the new firmware and keep my unlock
The new 4.0.1 baseband can be unlocked with ultrasn0w. You don't have to worry about that. Just be sure not to upgrade to 4.1 when it is released later this year.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.