Do you have to use pwnage and yellowsn0w to use a diff carrier?

Discussion in 'Jailbreaks and iOS Hacks' started by havenhamilton, Aug 6, 2009.

  1. havenhamilton macrumors 6502

    Joined:
    Mar 1, 2005
    #1
    i need to use my phone in japan, i've rented a sim card but i don't know if it will work with just pwnage or if i need use yellowsn0w or both. Thanks!
     
  2. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #2
    If your iPhone is not unlocked, you have to unlock it...

    That means using whatever you have to use for your model of phone.

    You can find the proper tutorials for each model on the Dev Team's links.

    Or just put the SIM in and see if it works... :p
     
  3. havenhamilton thread starter macrumors 6502

    Joined:
    Mar 1, 2005
    #3
    I need it ready to go before i get to japan. So pwnage unlocks and yellowsn0w makes it so i can use it on a different carrier?
     
  4. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #4
    What's your phone model, what's your computer? Tell us that info and we'll give you easy-to-follow instructions.
     
  5. havenhamilton thread starter macrumors 6502

    Joined:
    Mar 1, 2005
    #5
    iphone 3g 16 gb and im using a macbook pro intel. seriously, thanks so much!
     
  6. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #6
    OK, here's what to do, assuming your phone's already on 3.0.1. If it's not, update in iTunes.

    If you want to save contacts, texts, etc, back up the phone in iTunes. Then:

    1. Follow this tutorial to jailbreak your phone with RedSn0w:
    http://www.iclarified.com/entry/index.php?enid=4303
    (note, you must use the 3.0 firmware for this stage, NOT the 3.0.1 version.)

    2. Follow this tutorial to unlock it with UltraSn0w:
    http://www.iclarified.com/entry/index.php?enid=4253

    3. Restore from your back up
     
  7. havenhamilton thread starter macrumors 6502

    Joined:
    Mar 1, 2005
    #7
    Sorry I don't get it, I should upgrade to 3.0.1 or I shouldn't? or does that apply to the redsn0w program?
     
  8. megamanbnmaster macrumors 6502

    Joined:
    Jan 26, 2008
    #8
    use redsn0w instead of pwnagetool

    redsn0w/pwnagetool = jailbreaks
    ultrasn0w = unlocks.
    unlocking and using on different carrier = same thing.

    anyway, upgrade to 3.0.1, then run redsn0w and when it asks for firmware, use 3.0 firmware, follow the instructions and then you'll be set. After you're done, add the ultrasn0w repo and install ultrasn0w. That should make it work.
     
  9. havenhamilton thread starter macrumors 6502

    Joined:
    Mar 1, 2005
    #9
    Great, I did it and I think it worked. When I installed redsn0w it wouldn't connect to att. after i installed ultrasn0w att started working. I want to thank you guys for helping me out, I really appreciate it! Again, THANK YOU! :D:D:D:D
     

Share This Page