Dock disappeared, can't restart/shut down, DiskImageMounter deleted, etc, etc

Discussion in 'Mac Basics and Help' started by sabricorujo, Dec 2, 2009.

  1. sabricorujo macrumors newbie

    Joined:
    Dec 2, 2009
    Location:
    Lanzarote
    #1
    I've been happily in love with my iMac since 2006. Never had any problems.

    Just got back from working abroad over a month and my business partner (new to Mac) has been using my computer. Apparently the computer was switched on nearly 24/7 and only been restarted a couple of times.

    At first everything seemed fine until I ran the software update.
    First problem, there was an error when doing the security update so couldn't complete the whole update.

    iMac still working fine though...

    After restarting it all got really ugly.
    First, it took ages to startup, then the dock didn't load. Tried restarting at first, didn't respond, shutting down neither....

    Then when opening finder, the menus on the left hand side, Hard Drive, Documents, Music, etc... all gone...

    Most applications won't open... even some jpegs, pdfs, etc...

    Also the DiskImageMounter, Terminal and probably loads of other stuff has disappeared I'm not even aware of...

    Tried to open 'About this Mac'... no response...
    Tried to open.. 'Mac OSX Software' the following message appeared... Your system settings are being updated. Unable to open your preferred Web browser. Try again in a few minutes.

    I've been reading different forums and discussions all day... I've looked at the utilities folder, checked the CoreServices, tried 'killall Dock' (discovered that the terminal utility disappeared), etc, etc...

    I'm starting to get really annoyed and nervous... Don't know what to do!! :(

    HELP me PLEASE!!!!

    (Thank you) ;)
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    Sounds like the updater corrupted some files. Insert your computer's restore disk 1 and reboot, holding the C key from when you hear the startup chime until the Apple logo appears. When prompted, choose to do an archive & install, and select the "preserve users and network settings" option. Once the installer finishes, run Software Update a few times and everything should be back to normal.
     

Share This Page