Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

zyzz26

macrumors newbie
Original poster
Jul 10, 2017
27
1
hi, since update 10.13.1 the icons in the dock are very often damaged till i restart the mac.
update 10.13.2 didnt change anything.

i tried a clean new install of mac os. formatted the disk and made a clean new installation.
nothing helps

apple support just says boot into secure mode....

can anyone help?
 

Attachments

  • Bildschirmfoto 2017-12-08 um 15.16.49.png
    Bildschirmfoto 2017-12-08 um 15.16.49.png
    480.4 KB · Views: 190

fisherking

macrumors G4
Jul 16, 2010
11,177
5,515
ny somewhere
which apps are doing that? and what do the icons show in the Applications folder?? IF they're ok in the apps folder, remove the icons from the doc, and then put the apps back on the dock; if they're damaged IN the apps folder, that's a different issue...
 

Sital

macrumors 68020
May 31, 2012
2,109
870
New England
I've had the same issue a few times, but it's not just in the dock, it's also in the Applications folder. Booting in and out of safe mode does fix it. Alternatively, you can cmd-i on the app and drag any image into the icon at the top left of the Get Info window, and then immediately delete that icon image to reset the app icon. This is faster if there are only a few icons that aren't working.

You can also use a terminal command to reset the icon cache, but I've read mixed reviews on whether this works to fix the icons.
 

zyzz26

macrumors newbie
Original poster
Jul 10, 2017
27
1
which apps are doing that? and what do the icons show in the Applications folder?? IF they're ok in the apps folder, remove the icons from the doc, and then put the apps back on the dock; if they're damaged IN the apps folder, that's a different issue...
they are damaged in the apps folder too. all apps are damaged. one time its mail, the other time its safari or photoshop or any else
[doublepost=1512750746][/doublepost]
I've had the same issue a few times, but it's not just in the dock, it's also in the Applications folder. Booting in and out of safe mode does fix it. Alternatively, you can cmd-i on the app and drag any image into the icon at the top left of the Get Info window, and then immediately delete that icon image to reset the app icon. This is faster if there are only a few icons that aren't working.

You can also use a terminal command to reset the icon cache, but I've read mixed reviews on whether this works to fix the icons.
ok i will try booting into safe mode

tried safe mode, just worked for most of the icons, not all
 
Last edited:

saberwing

macrumors newbie
Oct 22, 2008
2
1
I'm having the exact same issue, it's really starting to become annoying if more than half of your icons have disappeared:
Q5JsKZ5.png

My personal hunch is that it may have something to do with the display settings of the screen, but I have no formal evidence to support that. I've only experience the problem when I'm running the 'more space' resolution on my MBP, but I haven't experienced the problem with the 'default' resolution. But like I said, it's just a hunch, because I have only ran it in default mode for a short duration.
 

zyzz26

macrumors newbie
Original poster
Jul 10, 2017
27
1
I'm having the exact same issue, it's really starting to become annoying if more than half of your icons have disappeared:
Q5JsKZ5.png

My personal hunch is that it may have something to do with the display settings of the screen, but I have no formal evidence to support that. I've only experience the problem when I'm running the 'more space' resolution on my MBP, but I haven't experienced the problem with the 'default' resolution. But like I said, it's just a hunch, because I have only ran it in default mode for a short duration.

hi, i contacted apple and in my case the programm: paragon ntfs for mac is making this problem, they say that little snitch can cause this too
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.