Resolved DP1 is fine, DP2-4 gives no sound/coreaudio??

Discussion in 'OS X Mountain Lion (10.8)' started by vicrep, Jun 13, 2012.

  1. vicrep, Jun 13, 2012
    Last edited: Jul 12, 2012

    vicrep macrumors newbie

    Joined:
    Jun 13, 2012
    #1
    I was wondering if I was the only one having that problem.

    Currently running MBP 8,1 (early 2011, 13" 2.4i5), and have been running MLDP1 without too many problems for almost 6 months. However, whenever I've tried to upgrade to DP2, 3, or even now 4, for some reason lose my coreaudio. The speaker icon in the menu bar is greyed out, coreaudio isn't in activity monitor, there are no sound drivers in audio midi setup, wifi, spotlight, etc are laggy like crazy, and I can't run system preferences without it stopping to respond. I checked all my pLists and other .components for core audio and they're all there and normal size... from looking at the pLists, it seems its the switch to sandboxing which may cause the problem.

    I was wondering if anyone has also had this problem, and whether someone could offer a possible fix?

    Thanks a lot
     
  2. vicrep thread starter macrumors newbie

    Joined:
    Jun 13, 2012
    #2
    Since the GM is out... thought I'd BUMP.

    Still same problem with the GM, and I think I've tried everything. Any help would really be appreciated.

    Thanks a lot
     
  3. xgman macrumors 601

    xgman

    Joined:
    Aug 6, 2007
  4. seclusion macrumors regular

    seclusion

    Joined:
    Jul 15, 2007
    #4
    Are u using a sound card?
    if you are, that soundboard has to have 64 bit drivers to work on DP 2 and later.
    I sold my Tascam controller soundcard for that reason
    Your internal Mac I/O should be working though.
    Hmm
     
  5. vicrep thread starter macrumors newbie

    Joined:
    Jun 13, 2012
    #5
    Thanks a lot for the replies!

    @xgman do you by any chance know how to do that through the terminal? The coreaudio crash means I can't use System Preferences. I didn't even know it could be disabled (silly me).

    @seclusion I thought that too, but even my internal sound card doesn't work. After opening Audio/Midi setup (which takes like 10min to open now), it shows no valid soundcards installed. Activity Monitor also shows no coreaudiod...
     
  6. vicrep thread starter macrumors newbie

    Joined:
    Jun 13, 2012
    #6
    FIXED IT!

    Thanks for your advice on the 64-bit thing. I uninstalled Euphonix Monitor Express (some old audio driver/router), and everything got fixed instantly!
     

Share This Page