dropped 2g in toilet now iTouch 4G mail losing passwords

Discussion in 'iPod touch Hacks' started by bogart, Sep 24, 2010.

  1. bogart macrumors member

    Joined:
    Mar 31, 2008
    #1
    Not sure where to post this.

    Dropped my 2G iTouch in toilet (accident) so upgraded to new 4G.

    Installed new one from backup of 2G. I have 8 mail accounts using imap for the inboxes (busy life), but several of them send via smtp with google mail accounts. Under the smtp configuration on the touch it lists several smtp servers with the same address "smtp.gmail.com" but with different id's and passwords (they are different gmail accounts), one of them as the Primary one. I use this same setup on iTouch and iPad and it worked very well until the new iTouch.

    On the old iTouch (and still on the ipad) if I use some software to send mail, such as safari sending a link or an rss reader to send mail to readitlater, then it would use the Primary smtp server and associated ID to send. When I do this on the new iTouch it seems to sometimes lose the password on that server and uses one of the other servers in the list and its ID instead. If I set the password it works but later stops working and when I look at the settings for that I find the password is now "Optional" greyed out.

    What am I looking at here - a bug ? a hardware fault ? Or just a screwed configuration because I installed from iTouch 2G backup ? Deleting the accounts and entering them manually is not terribly appealing (there *are* 8 of them). Or is this some feature of multitasking - I'm being very careful to quit all programs running in the background after a mail config change (just in case - so the settings get re-read) so I don't think its the latter and that would be crazy anyway.

    Anyone else encountered losing passwords this way ?

    Thanks

    andy
     
  2. bogart thread starter macrumors member

    Joined:
    Mar 31, 2008
    #2
    Its Safari overwriting the mail password

    No idea why - but I have a repeatable sequence.

    1 set a password for the Primary smtp server gmail account, save the settings etc.

    2. use Safari to send a link by mail

    Check the password on that server and its gone.

    Sigh ..... I'd just like my old 2G one back, everything worked, but its dead and gone back to Apple Heaven now. The wizards told me there is no afterlife for a drowned itouch.

    Next step is to remove the accounts and re-install them manually one by one.

    andy
     
  3. bogart thread starter macrumors member

    Joined:
    Mar 31, 2008
    #3
    Definitely - Safari causes mail to lose password on 4G

    Bug ?

    andy
     
  4. bogart thread starter macrumors member

    Joined:
    Mar 31, 2008
    #4
    Mail forgets oassword

    Tied it down more - ANY app sending any mail from outside the mail app (many respectable apps can do this) deletes the password on the default mail account.

    Anyone else experienced this?

    Andy
     

Share This Page