Egad! My Kernel is Panicking!

Discussion in 'General Mac Discussion' started by GeorgeTheMonkey, Aug 11, 2004.

  1. GeorgeTheMonkey macrumors member

    Jun 14, 2004
    It seems I'm having a bout of what some call "Kernel Panic," and to be honest, it's scaring me to death -- I've never been a very technically bright bulb when it comes to the down and dirty of computers, so I don't quite know what to do.

    I suppose it started yesterday: I was surfin' the net and all, when my dialup connection hung up. It's done it sometimes before -- I'm assuming it's my ISP's fault. In this case, it lost the connection -- the "other side was not responding" -- and started to Disconnect. However, as it sometimes also does, the modem would not stop disconnecting -- while it should normally only take 2 or 3 seconds to disconnect, in this case the computer would refuse to completely disconnect. It usually requires a reboot to set things all straight when this happens. :eek:

    This time, however, I got the bright idea to try taking care of the problem through other means. I opened up the Activity Monitor and basically Force Quit the AppleModemOnHold process (being used by my account) as well as the modemd process (being used by the root).

    But still nothing. Nothing at all. At this point, I believe I just turn off the power strip for it to reset and walk off in frustration. Egads, though -- I come back, expecting it to be booted up to the login window, and instead it's at a distorted screen with the original "White Apple Startup Window", and it's got a bunch of computer/terminal gibberish across the screen in very uncool, DOS-ish lettering. It would say:

    "Backtrace terminated;
    unaligned field address 0xFC14F427"

    ... and other such gibberish. (I thought that was the most key gibberish.)

    Erm, help then? :eek: I have no idea at this point what to do, and it's starting to worry me. :confused: I can still boot up and login, but I have to hold Apple-R and Option-P while doing so as per Apple's manual to do so. Otherwise, it just goes back to the kernel panic gibberish. :eek:

    (Thanks so much, in advance! :) )
  2. jsw Moderator emeritus


    Mar 16, 2004
    Andover, MA

    First, what type of system do you have (probably doesn't matter, just checking)?

    Second, do you have OS disks for your system (Panther, presumably)?

    Third, have you done the standard Applications->Utilities->Disk Utility-> select your hard drive and repair permissions thing?

    Sounds like you've seriously mucked up a file or two. Maybe something broke, and maybe that started it all, but the shutting-off-the-power-strip thing couldn't have helped.

    You might need to reinstall your OS (which isn't as horribly bad as it sounds).
  3. jsw Moderator emeritus


    Mar 16, 2004
    Andover, MA
    Forgot to ask: do you have AppleCare or are you still under warranty (or, more precisely, is your Mac)? If so, call Apple and tell them what happened. A situation like this is what the warranty is for....
  4. GeorgeTheMonkey thread starter macrumors member

    Jun 14, 2004
    Oh, doi. Probably should've listed my specs, while I'm asking a question.

    Dual 1.42 Ghz PowerMac G4, 1 GB RAM, running the latest -- 10.3.5. (Is it because of the upgrade that I'm having problems? I'd read of some kernel panic upon update over at Apple's Support forums.)

    I do have the Panther disks, for any reinstalling (egad :eek: ) that I might have to do. And I have tried repairing permissions; there doesn't seem to be any problem there. I think I'll go try booting from the startup disks, so that I can repair the normal boot harddisk. Suppose that might help?

    Heh, just my luck, to muck things up this badly. :rolleyes:
  5. GeorgeTheMonkey thread starter macrumors member

    Jun 14, 2004
    Unfortunately I don't believe so; didn't sign up for AppleCare because it was a desktop and I didn't foresee enough hardware-related problems to justify the cost at the time, and my computer is probably now a few months past the 1-year warranty.
  6. jsw Moderator emeritus


    Mar 16, 2004
    Andover, MA
    Well, I think your plan with booting from the CD and trying to repair things is a good one. Reinstalling the OS is enough of a pain that you'd want to put it off until trying those things.

    BTW - very importantly - is all of your important stuff backed up? If not, now might be a very good time to do so.
  7. GeorgeTheMonkey thread starter macrumors member

    Jun 14, 2004
    Arrgh, no luck --

    When I try booting from the Installer Disk, the kernel panic pops up first. It doesn't make it far enough to actually try to boot from the CD... (Erm, I'm guessing that might make things difficult for reinstalling the whole OS, too, won't it?)

    I did manage to initiate Single User mode and do a File System Check, though. :) That turned up nada, however -- both on the actual startup harddrive, and the Panther Startup Disk. :rolleyes: (I didn't realize it would check the CD when I had it in...)

    Am going to try booting from Panther disks one more time. Maybe it'll like me this time!

    (Oh, just thought of something! The cron jobs! MacJanitor, do your work. :D )
  8. GeorgeTheMonkey thread starter macrumors member

    Jun 14, 2004
    ARRRRRGH!!!!! Continued lucklessness. (Lucklessness? Luke Luck likes lakes. Luke Luck licks lakes. Luke Luck is rather luckless, though, when it comes to his PowerMac.)

    Was able to boot up with the Panther disks this time around; I had to trick it with a series of keyboard key actions. (Hold down Command, Option, R, and P until second bong; then hold down C as it boots to the CD.)

    Once there, ran Disk Utility. Repair Disk didn't turn up anything -- I'm assuming it did pretty much the same thing as the File System Check while in Single User Mode. However, I did repair permissions and it did some significant fixing on some Filesystems in the Library. I thought that would take care of it, but still no luck. :mad:

    Any other suggestions? I don't think I'm quite ready to just reinstall Panther... eeugh, that'd take a good day just to get all my files in order and backed up, and then after reinstalling it -- if that solves the problem -- I'd likely have to spend 3 or 4 days tethered to my modem, downloading software updates. (Darn dialup connection. :mad: )

    By the way, thanks once again. It helps to have somebody else beside you while going through the Dark Days of Macintosh. :(
  9. IJ Reilly macrumors P6

    IJ Reilly

    Jul 16, 2002
    Roughly in this order:

    1- Run the Hardware Test CD.
    2- Disconnect all peripherals.
    3- Reset the NVRAM.
    4- Remove as much RAM as possible.
    5- Run a deep disk diagnostic tool like Disk Warrior.
    6- If you feel the need to try reinstalling the OS (almost never fixes anything, but it's up to you), use the archive and install method, which is far less disruptive.

    Oh, and never pull the plug. If the Mac freezes up (or appears to), first let it sit for a while -- sometimes it comes back on its own. If you must shut it down, hold the power button down until it shuts off. Pulling the plug is to seriously risk hosing your hard drive.
  10. GeorgeTheMonkey thread starter macrumors member

    Jun 14, 2004
    Hehe, yeah, I know. It's just a really bad habit I have left over from my Windows days. ;) Sometimes it'd take a sledge hammer to fix those things! :rolleyes:

    Well, apparently there was a power outage while I was at work today. I set the computer to sleep last night -- I get back, and voila, all my clocks are reset and the computer is off. However, when I turned the thing back on -- no Kernel Panic! :D I have no bloody idea why, but at least for that time it didn't happen. :eek:

    Granted, the computer's date was set to December 31st, 1969, when it booted all the way up -- and for some reason iCal is reminding me of some pressing matter but not exactly showing what it is, and locking up before I can do anything further. But at least the Kernel Panic is gone. :cool:

    Am definitely going to go back and try your recommendations, though, IJ Reilly -- thanks for them! I'm still gonna key my eye out for any suspicious computer troubles, though it looks like they might have at least temporarily subsided.

Share This Page