El Cap = greater chances of USB drive death?

Discussion in 'OS X El Capitan (10.11)' started by orioncrystalice, Jun 28, 2016.

  1. orioncrystalice macrumors 6502

    orioncrystalice

    Joined:
    Jan 21, 2014
    #1
    So I've faced two hardware dilemmas while on El Cap (10.11.5, but the first problem occurred on 10.11.3) involving USB drives. Mac is mid 2011, 21.5".

    The first one was with my MyPassport Time Machine backup drive. On a normal backup schedule, Time Machine gave me the message that we would have to get rid of some old backups to make room on the disk. Done this plenty of times, no problem. Last time I did it was probably the final build of Yosemite. I give the ok, a short while later I get told it's unable to delete the old backups. Tried again, same thing. But it was your idea, Time Machine! I eject my drive because I need to bring it with me to the studio in case I need to throw some stuff on it. Get back from the studio, hadn't needed to use it. I decide to try cleaning up my backups again and plug it back into the Mac to do so. Nothing shows up for about 10 minutes and then finally it reads the drive and pops up. As empty, unformatted, and unnamed. Long story short, I couldn't get it to recognize it as my Time Machine backup, couldn't even get it to reformat via Disk Utility, and the Mac only read it one more time after that. Plugged it into the Windows 7 PC at work and it also doesn't recognize it. The hardware apparently works since the light blinks, but no computer will read this drive which used to have my entire life backed up on it, not even Disk Utility in Safe Mode.

    Part 2, which just happened the other day. Had a small USB with some random stuff on it I was poring through as I'm actively trying to get any semblance of old stuff that I might need back. The USB ports on some Macs seem to be a little finnicky as far as I can tell. I reach behind the thing to plug in a charger cord and accidentally bump the thumb drive. Not yanking it out at all, but just brushing against it. El Cap disappears it from the desktop and scolds me about not ejecting it. I've always ejected all my drives, so I figure this is just an oops, I take it out and plug it back in expecting to have to just recover one, two files. Nothing. Doesn't exist, doesn't read. Just now tried it on the work PC and it's the same thing. I'm convinced at this point that the Mac is going berserk on my USB stuff if it doesn't do absolutely exactly what it wants them to do. The only time I've heard of or experienced a drive completely failing and rendered unreadable is after multiple instances of yanking out of the computer, super old (really old) age, something going haywire during an attempt to erase free space. I'm planning to get a new Seagate 1 TB but at this point I'm pretty reluctant to plug anything at all into the back of the machine.

    Any similar experiences? Advice?
    --- Post Merged, Jun 28, 2016 ---
    Just saw a thread about a problem with disks ejecting after the Mac wakes up, but I think this thread is still relevant because in my case my stuff is straight up annihilated, so this is absolutely something that can happen....
     
  2. RichardF macrumors 6502a

    RichardF

    Joined:
    Oct 27, 2006
    Location:
    New York City
    #2
    Mac OS also killed my Seagate 2TB HDD. I was so pissed. Data I'll never get back.
     
  3. flowrider macrumors 601

    flowrider

    Joined:
    Nov 23, 2012
    #3
    Nope None!

    Lou
     

Share This Page