Enable three finger drag on Early 2008 MBP…(Finally)

Discussion in 'MacBook Pro' started by AnonMac50, Jul 28, 2010.

  1. AnonMac50, Jul 28, 2010
    Last edited: Jul 7, 2013

    AnonMac50 macrumors 65816

    Mar 24, 2010
    I have found the solution, and have posted it on posts seven and nine.

    The safest way though, is to use something like Kext Utility. It is built mainly for the Hackintosh community, but it also works great on a regular Mac.

    Also, if you use the Root account, the risk of messing up your computer is really low, and permission repair isn't necessary, at least when I did it. You can repair permissions if you want.

    For 10.6.4, you need the Multitouch update, you might also be able to do it without the update, but you would need to hack the kext, but that only gives inertial scrolling. I will try that later if I have time. As for 10.6.5, you need a new kext, I have uploaded one in a post below, but you can create one yourself. 10.6.6 uses the same kext, so if you used the combo updater, you will need to reapply the patch, but if you used the delta updater, you won't need to reapply the patch.

    Note: this is only for MacBookPro4,1 and MacBookAir1,1 and MacBookAir2,1.

    Look below for links to pre-made drivers.

    Also, I have uploaded a picture of the new Preference Pane.






    10.6.4 kext on first page.

    10.6.5 kext (works with 10.6.6 and 10.6.7).

    10.6.8 kext on 2nd page.

    I have also included kext from 10.7.1 on the second page.

    10.7.2 kext is also on the 2nd page.

    10.7.3 kext on 2nd page.

    10.7.4 kext on 3rd page.

    10.8 kext by modified by drFUNK on 3rd page (works with 10.8.1 and 10.8.2).

    10.8.3 kext on 4th page (works with 10.8.4).

    Have fun and Good Luck!

    Original question:
    OK, so with this new update, is there that option for the 3 finger drag for the early 2008 MBP? I mean how hard can it be for them to do it (isn't the late 2008 and early 2008 17" MBP the same except for a few specs like hdd???).

    Attached Files:

  2. SnowLeopard2008 macrumors 604


    Jul 4, 2008
    Silicon Valley
  3. Hisdem macrumors 6502a


    Jul 3, 2010
    Boca Raton, FL
    Plus the earlier ones non Unibody's don't have the multi-touch trackpad on them.
  4. iBookG4user macrumors 604


    Jun 27, 2006
    Seattle, WA
    My early 2008 non-unibody MacBook Pro can do every gesture that the unibody MacBook Pro can except for three finger drag...
  5. mgartner0622 macrumors 65816


    Jun 6, 2010
    Colorado, USA

    Yep, the last one or two generations of multibody MacBook Pro's can do most of the "new" gestures. They were the computers that pioneered the new Unibodys.
  6. AnonMac50 thread starter macrumors 65816

    Mar 24, 2010
    The 17" MBP unibody came in 2009, while the 15" came in 2008. The 17" has the same nonunibody (MacBookPro4,1) trackpad as the one before it (also MacBookPro4,1 which was released in 2008 February).

    Also, I am messing with the plists to try to get the drag working.

  7. AnonMac50, Aug 5, 2010
    Last edited: Jun 5, 2013

    AnonMac50 thread starter macrumors 65816

    Mar 24, 2010


    I did it!

    OK, I have uploaded the modified file you need to use. Install it to /System/Library/Extensions. Remember to repair permissions after installation (otherwise you will lose keyboard and trackpad functionality completely).


    Attached Files:

  8. soundguy15 macrumors member


    Dec 9, 2009
    I never could get this to work. what files did you modify inside of the kext?
  9. AnonMac50 thread starter macrumors 65816

    Mar 24, 2010
    First, open the kext (Show Package Contents), then go to Contents, then open Info.plist (I usually open it in Property List Editor that comes with Xcode Tools (comes on the OS X Install discs). If it opens in Property List Editor, then do the following:

    1. Go to IOKitPersonalities and open it
    2. On all the sections begining with WSTrackpad*3 (like WSTrackpadISO3) scroll down until you get "TrackpadThreeFingerDrag". Copy that line (it should have a tick next to it).
    3. Paste it in all the sections begining with WSTrackpad that don't already have it.
    4. Open Disk Utility and repair permissions. Then Reboot. You should have the option in the Trackpad Preference Pane. You won't get the video for the 3 finger drag though.

    You MUST repair permissions, otherwise you'll lose keyboard and trackpad functionality completely.
    Screenshots bellow:

    The first one is of the IOKitPersonalities section. The second one is for WSTrackpadISO3 with all the options. The third one is of WSTrackpadISO before editing and the last one is of WSTrackpadISO after editing.

    Attached Files:

  10. Zettt macrumors member

    Sep 19, 2009

    I did exactly what is mentioned here and can't get it working.
    I tried it yesterday evening twice.
    First I downloaded the kext in this thread, replaced it with the Extension on my machine and didn't have a keyboard after relaunch. Of course I didn't forget to repair permissions.
    Next I tried to add the keys with an editor by myself. Repaired permissions, restart, no keyboard.

    I realized that there are no keys "TrackpadThreeFingerDrag" in my Info.plist. Neither in the WSTrackpad*3 section nor somewhere else.
  11. AnonMac50 thread starter macrumors 65816

    Mar 24, 2010
    Did you install the multitouch update? You need that. Installing the update (or reinstalling it if you already did before) should fix it. You cannot get inertial scrolling on a without the update unless you have the latest MacBook or MacBook Pro, in which case, the update only brings 3 finger drag. After installing the update, try installing the kext included here.

  12. Zettt macrumors member

    Sep 19, 2009
  13. AnonMac50 thread starter macrumors 65816

    Mar 24, 2010
    I'm glad you got it working. :D Was it that you hadn't installed the update?
  14. Zettt macrumors member

    Sep 19, 2009
    Yes, the update. I totally read over that piece of information. :rolleyes: :D
  15. marienvo macrumors newbie

    Oct 11, 2010
    MacBook Air

    Just tried this on my MacBook Air and lost all keyboard and trackpad functionality. I did repair permissions after replacing the file. :(

    I guess I need to reinstall MacOS completely? Or is there a way to restore the back-up file?
  16. AnonMac50 thread starter macrumors 65816

    Mar 24, 2010
    Do you have Mac OS 10.6.4 and the multitouch update? If not, that might be your problem.

    You should be able to restore it. Simply delete the new file, and install the backup, and repair permissions.
  17. marienvo macrumors newbie

    Oct 11, 2010
    I restored the file, and ran repair permissions, but there still is no trackpad or keyboard functionality. :(
  18. AnonMac50 thread starter macrumors 65816

    Mar 24, 2010
    That is weird. Try reinstalling the multitouch update.
  19. marienvo macrumors newbie

    Oct 11, 2010
    Problem solved, somehow I needed to run the repair permissions twice, ran one after restoring the file, ran again after reboot, rebooted again, and now it seems to work fine again.
  20. AnonMac50 thread starter macrumors 65816

    Mar 24, 2010
    That's awesome!!!

    PS. Out of curiosity, have you installed the multitouch update originally?
  21. AnonMac50, Nov 10, 2010
    Last edited: Nov 10, 2010

    AnonMac50 thread starter macrumors 65816

    Mar 24, 2010
    Guess What. With this new 10.6.5 update, you have to redo the Three Finger Drag trick.

    EDIT: The new kext has WSTrackpad*4 and WSTrackpad*4a, as well as WSEvents*4 and WSEvents*4a. I'm guessing these are for either the new MacBook Airs, soon to come Macs, or both.

    EDIT 2: I have also uploaded the new kext for those who need it.

    Attached Files:

  22. AnonMac50 thread starter macrumors 65816

    Mar 24, 2010
  23. Maccleduff macrumors regular

    Jun 26, 2007
    So ... does the .kext in post 7 still work in Lion? :)

    Also.... I guess 4 finger drag i out of the question as its not a muli touch trackapad?
    (I have 2007 santa rosa MBP)
  24. Jantelagen macrumors regular


    Aug 4, 2010
    I wonder if this works on a white MacBook 2.1, mid 2007, the one officially capped at 2GB ram. Don't have the guts to try it out myself...
  25. AnonMac50 thread starter macrumors 65816

    Mar 24, 2010
    I don't think so, but, you can make your own one from by following the steps.

    3 finger drag (or any other 3 finger gestures) will also not work, as that also needs the "multitouch" trackpad. The kext will install fine, and it would work when you target disc mode boot it off a computer that supports it.

    It won't change anything on your computer, but if you target disc mode boot your computer on another computer that supports it, it would work on that computer.


Share This Page