epson stylus photo 2200 frozen?!?

Discussion in 'Mac Accessories' started by bhartley, Nov 6, 2005.

  1. bhartley macrumors newbie

    Nov 6, 2005
    Hi there... I need some suggestions... I have the epson 2200 printer. First, just in case, I don't think this caused my problem but it may have. I hooked it up again (after it was idle for six months) using the firewire cable. I somehow attached the cable in opposite to (180 degrees) how it was to go in properly. I don't know if this caused the problem or not... but after checking the cable, after first having no luck with the computer software stuff, I realized my mistake and attached it properly. I thought I solved things...

    The epson printer utility is not recognizing the printer being attached. My mac, through the system profiler, is also not recognizing anything attached via the firewire.

    The printer setup utility does not load the new drivers - though I have downloaded the most resent from epson and installed things and then restarted...

    The power button on the printer comes on when I power up the printer (and it makes a slight noise as the print cartridges sound as if they quietly check that they are correctly placed - I think anyway) but:

    1. I cannot power it off (when I press the power button so it goes in the raised "off" position the green light still stays on!)

    2. When I go through the EEPROM and Timer IC reset (as I think the printer should reset itself every time it gets powered on right??) it simply shuts down and the power button does not work at all (no green light shows) even if you press the power switch a number of time. You have to unplug and then plug it back in again.

    To go through the reset switch I mention above, you have to power off the printer. Turn it on while holding down the roll and paper switch buttons... when the power and paper LED lights blink twice, and then all other ink LEDs start to flash, you release the paper and roll switches, and press the paper switch. This basically should then reset the EEPROM and IC (I don't know what either stand for as I'm just trying to restore my printer)...

    But the power and paper LED lights never do flash twice and all lights simply start flashing red. After though pressing the paper switch... the printer shuts off and the power switch is useless.

    Please help... I have no solutions whatsoever...

    In case it helps:
    2.0 ghz g5 duel
    10.3.9 os x
    1 gb ram

    and one really confused guy

    b :confused:
  2. FocusAndEarnIt macrumors 601


    May 29, 2005
    Gosh man, I dunno what to say. Have tech support/warranty? Call 'em. Just don't tell 'em about what you did to the port :p
  3. Bear macrumors G3

    Jul 23, 2002
    Sol III - Terra
    Does the printer properly powercycle when the firewire cable is not plugged into it? Also, check the firewire port for bent pins.

    Also, try USB and see what happens. Note that you can only have the USB or the firewire port connected at any given time. I would recommend removing the firewire cable from the printer when you try the USB cable.
  4. CanadaRAM macrumors G5


    Oct 11, 2004
    On the Left Coast - Victoria BC Canada
    Does the Mac recogize a Firewire hard drive or DVD/CD? Plug a known-good Firewire peripheral in.
    Does it say anything at all in System Profiler under Firewire, even unrecognized device, or does it say literally nothing or "no information"?

    If nothing, then you have burned out the Firewire chip on your Mac motherboard and/or the chip in the Epson, by applying Firewire buss power to the data lines.

    Sorry, I hope you have Applecare on the G5 and that they don't ask how it came to be not working.
  5. bhartley thread starter macrumors newbie

    Nov 6, 2005
    Some more details/follow up...

    Thanks for your suggestions Bear. I don't think the printer power cycles properly, even when the firewire cable is not plugged into it. With the cover up and as you turn on the power, the print cartridge moves slowly to the end, in a very small movement from where it is, and then back, and stops. And that's it. It doesn't go through any cleaning cycle either. It appears to do the same with the cover down too. It doesn't appear either that anything is "stuck".

    I've tried initiating a cleaning cycle too... by holding down the ink button when powering it up and having a sheet of paper in the printer ready to go. Nothing... just that all lights flash. And when I release the ink button, the printer powers down even with it the power switch being in the "on" position (no green light is present). The power button is useless unless you unplug the printer and plug it back in again.

    I've tried to "jimmy" (just move around a bit) the ink tray as maybe this is causing it to freeze? The firewire attachment seems to be fine. It really wasn't hard to put the cable in the wrong way surprisingly.

    CANADARAM: Thanks for your thoughts too. I've plugged in an old firewire external hard drive. It works fine (phew!). I'm wondering if I "tripped" something in the printer motherboard?

    As mentioned before... when I power it up, but then becomes unresponsive... the green light on the power stays on, but the computer does not recognize the printer and I can't turn the printer back off with the power button (which stays on in the "off" position).

    I don't get this at all...

    I sent a note to tech support (Epson) but I'll have to wait to hear from them next week I think. I'll see if I can find a 1-800 number later... but if I find out... I'll post what was wrong with it...

    Keep the help coming!

  6. sand2008 macrumors newbie

    Oct 29, 2008
    what solution?

    Sorry to remember you bad souvenirs (almost three years) but I have exactly the same problem. For it started when I wanted to switch on the printer and then the same story (cannot switch off, green light on, printer not recognized by my mac...). Please let me know what is the solution or if my printer simply dead...
    Thank you very much for your reply, which will be really appreciated.
  7. bhartley thread starter macrumors newbie

    Nov 6, 2005
    sorry to hear

    Hey Sandrine,

    I'm sorry to hear you seem to have the same problem. I wasn't able to get anywhere with the printer. I took it to an epson certified place to get it looked at. After talking to the repair place epson Tech support, I think we concluded that it could have been a motherboard issue - and that the 2200 doesn't have a reset function we could try. So there was nothing I could do.

    At that point, I think, epson was coming out, or was coming out, with better printers and inks... and it was going to cost at least 500 buck or more I believe to fix it... so I felt it wasn't worth fixing.

    I've actually bought the 4880 and it's pretty cool. I definitely need to use it more. It's great to see that there is a replacement for the 2200... 2880. Something to consider. I just wish I knew what happened to my printer - if it was my fault, that I somehow damaged it someway, of it was just a freak event that happened to it. Hopefully my new printer will last for years to come.

    Thanks for writing. I wish the best. I forgot that I've written to this forum - so should the others discover that I've written to this - I just wanted to say thanks again for their help.

    Take care,


Share This Page