Erased fusion drive in recovery and now I'm stuck

Discussion in 'OS X El Capitan (10.11)' started by mdarwish313, Jul 12, 2015.

  1. mdarwish313 macrumors newbie

    Joined:
    Jul 12, 2015
    #1
    Hello, I own an imac 5k 8gb, 4gb graphic, 3tb fusion drive.

    I recently was on the latest version of OS X Yosemite, the one with Apple Music. So the first public beta of El Capitan was released and after I researched, most people said it's quite stable, so I decided to install it. As Apple advice, I backed up my imac through Time Machine on a 2tb western digital external HD formated by the Time Machine app itself. My backup size was 1.6 TB so I left it finishing its job. Unfortunately after reaching 1.2 TB of backing up, Time Machine failed for some reason.

    I just felt disappointed and went on with installing El Capitan without the backup.

    Installation went fine, but after using it few days, I reliazed it was a bad idea installing it since it was in beta and some of my key applications were not working. I realized I jumped very fast on the board, and hopefully I will be a lesson for others.

    I thought of going back to Yosemite, but there are no articles on the Internet guiding us to downgrade for those without a backup. I tried entering Internet Recovery mode by Holding command control R, but didn't work, so I entered Recovery Mode using command R at boot. Then I went to disk utility (the new one) and clicked on my 3TB HD and clicked on erase. It was something like Fusion Drive > Macintosh HD. I clicked on Macintosh HD, erase button was activated. However it ended up with an error for some reason. I cannot reproduce the error message because now the drive just doesn't appear. Only Fusion Drive on the top, with an option to partition.

    I try to partition and it gives me this error :

    "Internal Error

    An uncaught exception was raised. Choose "Continue" to continue running in an inconsistent state. Choose "Crash" to halt the application and file a bug with crash reporter. Choosing "Crash" will result in the loss of all unsaved data."

    If I click on Show Details I get more information but since I'm on my iPhone and it's full of codes, I cannot type them. I try to grab a picture.

    Also clicking on First Aid gives me an error. When clicking on Show Details, it is written: "The operation couldn't be completed. (Cocoa error -1.) Operation failed..."

    If I exit Disk Utility and click on Reinstall OS X, El Capitan's window will appear, but when I click on Continue, it reminded me that "To download and restore OS X, your computer's eligibility will be verified with Apple." I click on continue, a loading bar appears saying: "Loading Installation Information..." but after a while I get this message: "Could not find installation information for this machine. Contact AppleCare."


    I have also tried from a bootable Yosemite DVD, went to disk utility (the old one) but still the drive does not appear, repairing it shows everything is healthy. Partitioning is inactive.

    Today I was able to get into Internet Recovery mode.

    In Disk Utility, I see Macintosh HD. When I verify or repair it, it gives me no error, and tells everything is healthy, but when I go to partition tab, I cannot partition it. All the buttons are inactive there. A message is present there saying: You cannot partition the full size of Macintosh HD.

    When I go to Reinstall OS X, Yosemite installation wizard appears.

    I will take you through the steps with pictures.



    I then click on Continue

    [​IMG]




    I click on agree

    [​IMG]




    Unfortunately no disk appears here!

    I will also give you some snapshots of disk utility:

    [​IMG]




    [​IMG]




    If I click on repair disk, this appears




    [​IMG]







    Here is the screen also if I click on the Info button on top left corner of disk utility :




    I hope we are able to fix it through Terminal or something, I'm really stuck.
     
  2. mdarwish313 thread starter macrumors newbie

    Joined:
    Jul 12, 2015
    #2
    Here are some snapshots
     

    Attached Files:

  3. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #3
    Seems current el capitan has serious issue on utilising fusion drive.

    Since now you cannot even make a new partition, it is not possible to use another partition to install Yosemite and bring your key application back to work.

    If I were you, I would use external drive to install Yosemite on it, and go through work by booting from that external drive.

    Could you boot your iMac into target disk mode, and attach it to a Windows machine to format the disk? I know this is crazy, although, it might work, might. This is because Windows may be able to destroy partition it does not recognise by force. I never did this before. :(

    In the meantime, I recommend you do a backup of your whole disk by using time machine on el capitan, full backup, just in case data ca be accessed later?

    For apps not working, you can try to check package contents, and go to MacOS folder, and double click the item with terminal icon to see if your app would work. But if your app relies on Java SE 6, this may not work. I use this weird way to bring Xcode 6 back to work in beta 2.

    I don't know if this could help. You could try if it is convenient for you. :)
     
  4. mdarwish313 thread starter macrumors newbie

    Joined:
    Jul 12, 2015
    #4
    Hello Shirasaki, the problem is that I cannot boot into el capitan anymore. Since I went on recovery mode and erased the drive, although it ended with an operation fail, my drive disappeared from disk utility. Now when I boot my imac it straighly goes to recovery mode. Even if I click on Startup Disk, my drive is not there. Also as you see in one of the screenshots, when I try to clean install Yosemite, no drive is there to be installed on.

    Isn't there any way through terminal to reset a fusion drive to its original state?
     
  5. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #5
    I have no experience on using fusion drive. But you could first type "diskutil" under terminal and see if any command is used for listing your drive. And use "mount" Command to try mounting it under recovery environment. If there is any error, you will know.

    You may try to reset your disk under Windows environment using some third party utilities. I am also a Windows user so I may use this way if possible.
     
  6. mdarwish313 thread starter macrumors newbie

    Joined:
    Jul 12, 2015
    #6
  7. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #7
    This is a really great idea to seek for help, and you are so lucky that you have found a senior advisor. This might be the reason why you can get your issue solved faster.

    And I have seen all screenshots. The method he provides is simply awesome. I am sorry I could not provide much help since I am a newbie of Mac OS X and UNIX system.

    And it seems that using external disk to install system and keep personal files inside internal drive is a better way, but thunderbolt external drive is pricy, and you may only use it under Mac for its best performance. USB 3 is a better choice, and since your iMac has four ports, it is ok for you.
     
  8. Jonnoy macrumors newbie

    Joined:
    Sep 18, 2012
    #8
    Please may you re-post this picture? I'm having the exact same issue and stuck with a bricked iMac! Thanks
     
  9. Scyllinice macrumors newbie

    Joined:
    Sep 30, 2015
    #9
    I had the same problem.

    Since I had a backup, I just did step 8 and 9 of the following guide and that brought my fusion drive back as a selectable option to install El Capitan to.

    I did this in the Recovery mode (command-R) and selected Terminal from the utilities menu.

    http://blog.macsales.com/15617-creating-your-own-fusion-drive
     
  10. utente__mac macrumors newbie

    Joined:
    Sep 20, 2015
    #10
    Safari only says iCloud couldn't find the image. Could you please upload it somewhere else? Thank you in advance.
     
  11. Jonnoy macrumors newbie

    Joined:
    Sep 18, 2012
    #11
    Thanks pal, I ended up finding this exact same site in the small hours last night. This and another guide for deleting the core storage profile before this got it sorted.
    Was more of a painful introduction to the new OS than I was expecting!
     

Share This Page