Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Error Code -1008f after reinstalling OSX from Time Machine on a Macbook Pro 2018

M0sea

macrumors newbie
Original poster
Aug 21, 2020
1
0
I'm brand new to this forum but I've frequented it a lot as a reader for the last 10 years.

If anyone can help me with this before I need to enter the trenches that is apple support.

My wife recently got herself a new laptop from work. As mine's already feeling it's age I wanted to taker her up on her offer and upgrade to her old Macbook Pro 2018 13''. So I got to work and after backing her stuff up with Time Machine I plugged in my own Time Machine, restarted the Macbook and selected "Restore from Time Machine" as I have done a lot of times before when adapting a new (or used) laptop. Took 2 hours and it was done. Then the globe popped up and wanted to connect to the internet. The loading bar appeared and after 3 minutes an alert symbol popped up over the globe stating the error code -1008f. Since then I've spent hours trying to figure this out. I've found this thread on apple support: https://support.apple.com/en-us/HT206989
I've followed all the suggestions to a tee. First we deleted the Macbook from my wives Apple ID. We double checked that it's gone and deleted from there. Then I've tried changing the access point, I've connected it to the mobile internet of my Iphone and I've setup a boot disk with Catalina on a USB hard drive. The computer recognises my hard drive when booting up but when I select it it just starts a regular internet recovery anyway.

I've also tried to get the Macbook to recognise her old Time Capsule update, but the hard drive won't be recognised, no matter what I try. I have a hunch that the source of the problem is the Apple T2 Security Chip and the safety options involved. I haven't known about this before trying to reinstall this laptop but reading up about it, it seems that this could be the problem. Other than that I'm at the end of my wits.

Help would be much appreciated. Thanks in advance!

Cheers
M0sea




It says to turn off act
 

Taz Mangus

macrumors 603
Mar 10, 2011
5,084
1,231
I think what happened to you was the Activation Lock was not turned off and now the T2 chip is preventing you from booting into the normal OS. You might need to call Apple Support on this one. There is a thread about this in the Big Sur forum.

Ahh the days when things were simpler.

 
Last edited:
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.