excel workbook quits every time it's opened

Discussion in 'Mac Apps and Mac App Store' started by QCassidy352, Sep 13, 2004.

  1. QCassidy352 macrumors G4


    Mar 20, 2003
    Bay Area
    This is a file that my gf really needs for work. Every time she opens it, excel "unexpectedly quits." Same thing happens on my computer.

    It only happens with this one file - every other excel workbook opens as normal. Sometimes, when we reopen excel after a quit, it will, by default, open to a certain file. When that happens, it is possible to open the problem file by opening it as a copy or as read only from within excel- not as the original.

    However, any attempt to copy the data to another file or to save the file under a different name causes excel to quit.

    The file will open on a PC, but that's not an option for her to do her work.

    It seems this document is corrupted. Do you agree? What can be done? This is very important for her job...

    G4, 10.3.5
  2. Savage Henry macrumors 65816

    Savage Henry

    Feb 20, 2004
    in a one horse, two house, three pub town.
    Does sound busted.

    Tried your temp directories for backups?
    Opening in another application/compatible office suite?
    When you are copying the data are you copying entire sheet tabs or just sections of data? - On knackered files like this I tend to just copy the area as there maybe something in the tab that blows it.

    Can't think of anything else for now, so good luck.
  3. QCassidy352 thread starter macrumors G4


    Mar 20, 2003
    Bay Area
    where are these "temp directories" you speak of?

    It opens in appleworks, but much of the data is missing, and it's all on one page rather than multiple sheets (it's a TON of data). Downloading openoffice now to give that a shot.

    Have tried copying both the whole, and a sheet at a time. No good.

    Need help!

    Any reason why appleworks isn't getting all the data? File too big maybe?
  4. emw macrumors G4


    Aug 2, 2004
    This sounds like it might be formula-related, so you can try a couple of things to find out (I am assuming this sheet contains no macros - Excel would tell you if it did).

    1. Open a copy of the file, select all, and then Paste Special... into a fresh document and select values. Try and save. If it works, it could be a formula problem.

    2. Go to Excel Preferences>Calculation and set calculation to manual and turn of "Recalculate before save" then try and save. If this works, then this is another indication of a formula error of some sort.

    The question is, if it turns into a formula error, I'm not quite sure how to fix that. You could try selectively copying only parts of the document and saving as you go, but first, I also thought of this...it may be an error with something that Excel uses called "Add-ins".

    If you go to Tools>Add-ins... you can see what is active. If there are any active, try deactivating, opening and saving. If that works, you may need to re-install the add-ins (or Excel) from scratch? Since it is producing errors on both your and your gf's Macs, though, it is probably not a bad add-in, but it may be a missing one.

Share This Page