Exposé Desktop (F11) Not Sticking

Discussion in 'macOS' started by blufire, Aug 3, 2005.

  1. blufire macrumors regular

    Jul 20, 2002
    Hello, I'm running 10.4.2 on a PowerMac G4 Dual 1 GHz (MDD), and I've had this problem since I installed 10.4. After running for a while (perhaps 30 minutes or longer), using Exposé to reveal my desktop (by pressing F11) will only hold for a few seconds. The time that the desktop remains showing varies from immediately closing back to 5 seconds. I can't find any particular program or function that this happens after; it seems to be random. (Nothing is happening that would cause it to close back either, such as launching a program.) Does anyone know what could be causing this [mis]behavior?

    Thanks a bunch!
  2. freiheit macrumors 6502a

    Jul 20, 2004
    Haven't seen that one, how about this?

    Does it happen every time? Also, if you setup a Hot Corner to perform the same Expose function, does using the hot corner work or display the same weirdness? If the corner works, maybe your F11 key is getting stuck, I don't know.

    I haven't noticed any similar behavior on a dual 1.25 FW800 (essentially the same as the MDD) with Tiger 10.4.2.
  3. blufire thread starter macrumors regular

    Jul 20, 2002
    It seems like it happens pretty much every time. The key isn't physically sticking, and carefully pressing it doesn't reveal any sign of a hardware problem. For some reason, it's working properly right now (I haven't restarted), and I tried the hot corner, which works as well. The reason I'm convinced it's software and not hardware is (1) due to the appearance of this behavior only after installing 10.4, and (2) if the key is sticking somehow, then Exposé should invoke too, not just fall back after invoking.
  4. killmoms macrumors 68040


    Jun 23, 2003
    Washington, DC
    Someone else had this problem recently, turned out a Dashboard widget they had was causing the problem. Close some custom widgets, if you have any, see if that fixes it.
  5. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    A DB widget? That's really interesting. I found an interesting thing... I had this issue sometimes when I was plugged in to a second screen (the additional screen was a 2001FP @ 1600x1200, in addition to my iBook G4's main screen). But it has not reared its head up unless I was screen spanning.
  6. savar macrumors 68000


    Jun 6, 2003
    District of Columbia
    The other advice is good, but you also realize that expose has two modes of operation? If you click fast, then it comes up until you click again. If you click for longer than the double-click time span, then expose goes away as soon as you release the button.

    I can't tell from your description if this is the kind of problem you're having or not, but its something I learned recently and I figured most others don't know either. If this is not your problem, sorry for contributing noise!
  7. blufire thread starter macrumors regular

    Jul 20, 2002
    I do know about this functionality, and no, that's not what's happening. :) I'm referring to the toggling action rather than the temporary one. But thank you for the thought!
  8. blufire thread starter macrumors regular

    Jul 20, 2002
    I believe I have narrowed it down to the Dashboard. The desktop Exposé function was acting up again as mentioned before, so I tried the hot corner and it still did the same thing. Then I activated Dashboard briefly, and the desktop function is working as expected again. I'm not sure which widget is causing it, but I hope Apple and/or the widget writers can clear it up... I'm submitting a bug report to Apple about this. Thanks everyone for your help!

Share This Page