Exposé & Dock sporatically fail to operate

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by Monk Edsel, Oct 10, 2004.

  1. Monk Edsel macrumors regular

    Apr 7, 2004
    Hi. I'm running Panther on a revision C 12" PowerBook. I've had it for a few months, and so far everything has been great with one exception: after using the PowerBook for awhile (hours and hours), the Dock will fail to appear when called with the mouse pointer, and Exposé no longer functions. I also cannot restart, log out, or shut down when this occurs (it begins the process but hangs, spinning the beach ball for awhile and never actually shutting anything down). Everything else seems to function normally during these episodes. I believe this started happening after installing some app that "unlocked" "hidden" features of the OS, namely additional minimization animations and an alternate way of revealing the desktop through Exposé (shrinking all the windows to what was essentially an icon on the desktop, instead of pushing everything out to the edges of the screen). I ended up ditching this software because it would often lock up in the midst of minimizing or using Exposé. I also discovered that it was optimized for a previous build of Panther. Of course, for all I know this has nothing to do with it, but I am fairly certain it does. I am wondering if anyone can think of a simple fix for this, perhaps a preferences file that was altered in some strange way that can be deleted. I have tried fixing permissions many times. I really appreciate any one who can help me fix the one and only issue that has truly sullied my otherwise perfect Mac experience.
  2. stoid macrumors 601


    Feb 17, 2002
    So long, and thanks for all the fish!
    I'm guessing that you installed TinkerTool, and since it modifies system level resources a simple drag application to trash won't work like most apps. I would suggest re-installing TinkerTool, or whatever haxie it was that you installed earlier, and finding a setting that restores system defaults. If that can't or doesn't work, you may be stuck re-installing Panther.
  3. Monk Edsel thread starter macrumors regular

    Apr 7, 2004
    Yes, it was TinkerTool. The TinkerTool page (http://www.bresink.de/osx/TinkerTool.html) says this about it: "The program will never change any component of the operating system, so the integrity of your system is not put at risk, and there will be no negative effect on system updates.

    "All preference settings changed by TinkerTool can be reset to Apple's defaults, or to the state that existed before using the tool. No dangerous background processes are used for TinkerTool's operation."


    Also on the TinkerTool page, there is an un-installer. I downloaded it and ran it but it didn't seem to do anything. The application that opened just had a few grayed out options in the menu bar with nothing else on screen. Maybe that was all it took.

    At any rate, before I trashed it the last time I did reset to defaults. The funny thing about doing that was that it reset some features to settings other than the default. The only example I remember was that it set the hard drive to never turn off and I know for a fact that it was never set that way before, I never touched the setting. So, go figure.

    I downloaded the latest version and ran it, and told it to reset everything to default again anyway.

    Then, on a whim, I searched the hard drive for "TinkerTool" and it turned up three files, a preferences file and a couple folders. I deleted them.

    So, we'll see what happens.
  4. Monk Edsel thread starter macrumors regular

    Apr 7, 2004
    Well, none of the above worked. I noticed this time the computer gets really laggy before Exposé and the Dock fail; you click on something and it takes 5 seconds before anything happens in any given program. I also was running LimeWire and during this time the list of search results kept flickering in and out, something i never saw happen before.

    Sigh. I really do not want to reinstall Panther. :(

Share This Page