Exposé hot corners not working after unplugging external monitor

Discussion in 'macOS' started by NateP, Mar 22, 2009.

  1. NateP macrumors member

    Joined:
    Sep 20, 2005
    #1
    I have an issue that's finally just frustrating enough to want to fix it.

    I use Exposé's hot corners on my Al MB. I also use an external monitor at my desk. When I unplug the monitor to disconnect the laptop from being "docked" (as it were), I find that I can't use hot corners anymore. If I restart the Finder, that doesn't fix the issue. If I go to Exposé preferences, and change a hot corner preference (e.g., what gets done when one goes to the upper right corner), then things get fixed.

    But I really don't want to go to Sys. Prefs. each time I change monitors. Is there any other solution?
     
  2. MistaBungle macrumors 6502a

    MistaBungle

    Joined:
    Apr 3, 2005
    #2
    Is the monitor used as a mirrored display or just as extra screen real estate? Like, does the external get the menubar at the top?
     
  3. NateP thread starter macrumors member

    Joined:
    Sep 20, 2005
    #3
    Extra real estate. The external gets the menubar at the top. Usually I run it with the MB's lid closed, but since the dimensions of the screens are different, I don't want to simply mirror.
     
  4. NateP thread starter macrumors member

    Joined:
    Sep 20, 2005
  5. magz0r macrumors newbie

    Joined:
    Mar 28, 2009
    #5
    Well, I have a suggestion, but it doesn't really solve the problem. If you press Opt + F2 and switch between two different resolutions it reenables the hot corners, at least on my macbook. You can also enable the display icon in the menubar and just switch between two resolutions from there. At least it's shorter than entering sys. pref's.
     

Share This Page