Exposé stops working

Discussion in 'macOS' started by tuleby, Dec 1, 2007.

  1. tuleby macrumors newbie

    Joined:
    Dec 1, 2007
    #1
    Hi

    I have a new MacBook Pro which is a few weeks old. Leopard is installed and updated.

    After what seems to be a random amount of time, exposé stops working. I can not use hot cornes, not appswitch with cmd-Tab, no show-all-windows (which I access through the mighty mouse side buttons) etc.

    After a reboot it works fine, for a while.

    This happens every day and I have to reboot like 5 times a day :(

    Any ideas? Any dirty solution to "reboot" exposé instead of a full reboot?

    Thanks
     
  2. Quasiportnoy macrumors regular

    Joined:
    Oct 1, 2007
    Location:
    Baton Rouge, LA
    #2
    You could try restarting the dock, and that might do something. Type "killall Dock" in the terminal, and maybe that will restart Exposé somehow.
     
  3. tuleby thread starter macrumors newbie

    Joined:
    Dec 1, 2007
    #3
    Naah, almost worked. I got back the ability to use hot corners but app-switching and the shortcut connected to the side buttons of the mouse still do not work..
     
  4. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #4
    is it time machine that stops exposé and dashboard keyboard from working? this is what happens to me and its really annoying. i hope apple will fix this bug in the future.

    to test reapply you exposé shortcuts and head into time machine and restore or delete a file.
     
  5. tuleby thread starter macrumors newbie

    Joined:
    Dec 1, 2007
    #5
    OK, thanks. I have not activated Time Machine though, but I will re-set the shortcuts and test. Note that it is not only shortcuts that stops working, not even the Cmd-Tab appswitching works.
     
  6. danielsan1701 macrumors newbie

    danielsan1701

    Joined:
    Feb 8, 2006
    #6
    "killall Dock" in the Terminal totally worked for me. Thanks!
     
  7. CyrusOz macrumors regular

    Joined:
    Mar 15, 2009
    #7
    Ok so for the new mac users, where is this 'terminal'?
     
  8. jdwyah macrumors newbie

    Joined:
    Mar 23, 2009
    #8
    garrr! this sure is annoying.

    killall Dock fixes hotcorners, but everything else is still hosed. seems like ctrl and command keys are hosed in Finder?

    They work in other apps. Anybody got another idea for something else to killall?
     
  9. czesco macrumors newbie

    czesco

    Joined:
    Dec 8, 2008
    Location:
    North America
    #9
    Easier Fix

    I have this same problem and I have found a much easier temporary solution than I've seen here. I open Force Quit (shortcut: option+command+escape) and relaunch Finder. Expose then works fine (until it stops working again). It's a much quicker solution than a complete restart and much more simple than messing around in Terminal (especially if that isn't something you're comfortable with).

    I hope Apple fixes this issue because it is really annoying.
     
  10. dav146 macrumors regular

    dav146

    Joined:
    Dec 21, 2007
    #10
    killall Dock

    magic! What a simple solution to such an annoying problem!

    I found that my alt - tab functionality fell over and required the above to kick it back into touch.

    Thank you!
     
  11. nodakjones macrumors newbie

    Joined:
    Mar 4, 2008
    #11
    killAll Dock worked great for me.

    Such an annoying problem that has plagued me for two years. I finally got fed up with rebooting, found this post and tried 'killAll Dock' from the terminal. It looks like it is working!:)
     
  12. Jisuo macrumors 6502

    Joined:
    Dec 4, 2008
    Location:
    Sweden
    #12
    Use spotlight.
     
  13. MacSimoPark macrumors member

    MacSimoPark

    Joined:
    May 19, 2008
    Location:
    UK
    #13
    Anyone else finding that killAll Dock isn't restoring four-finger exposé functionality?

    I've tried killAll WindowServer, but no joy.

    Any ideas for a shorter way than just restarting every time?
     
  14. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #14
    It should be in your Applications/Utilities folder. Also, it was in my Dock by default. If not there, you probably removed it. It's a good idea to know what it is that you're removing. ;)
     
  15. docspal macrumors newbie

    Joined:
    Nov 1, 2010
    #15
    The Expose hot corners issue recently appeared on my MacBook Pro. I tried killall Dock but that didn't fix it for me. I still have to reboot to get hot corners to work again.
     
  16. dmchapman macrumors newbie

    Joined:
    Apr 6, 2008
    #16

    I've seen this a few times (on Macbook, iMac and my G5 Macpro). The killall dock solution works *if cmd tab switching is broken* IME.

    If it's just hot corners then either a reboot (bit drastic) or putting the mac to sleep and then waking it is the only solution I've found.

    Annoying, but it doesn't do it often enough for me to dig much further.
     
  17. Richard1028 macrumors 68000

    Joined:
    Jan 8, 2009
    #17
    My hot corners fail to work every now and then.

    If you run the Expose & Spaces utility (from System Preferences) then simply close it, all seems to get reset as OSX just assumes you changed something.

    Works for me anyway.
     
  18. mrbrent311 macrumors newbie

    Joined:
    Apr 20, 2011
    #18
    Killall Dock Works

    boom bam, done, killall Dock in the terminal works
    :)
     
  19. sprale macrumors member

    Joined:
    Oct 23, 2007
    Location:
    Republic of Texas
    #19
    My hot corners usually fail, but the hot keys continue to work. This usually happens right after having to force-quite Firefox. "killall dock" only respawns the dock process.

    Oddly enough, unplugging my Logitech keyboard and mouse does the trick, though the hot corners were also failing when using the trackpad.
     

Share This Page