Extreme external HD “Read-Only” challenge: No solution??

Discussion in 'Mac Basics and Help' started by snogger, Jun 6, 2014.

  1. snogger macrumors newbie

    Joined:
    Feb 5, 2009
    Location:
    Seattle
    #1
    Hello, I’ll get right to it! :)
    [Apologies if this has been posted elsewhere but from what I've seen on the web, it hasn't…]

    The question is this: Under what circumstances is it be impossible to bring an external hard drive out of a read-only state? And: why would a hard drive change itsself from “Read /write” to “read only”?

    Brief context:

    I have a 4TB G-Drive hard drive that has magically become a read-only drive with some severe problems. All attempts at finding a solution have failed (all).

    Longwinded context/series of events:

    1.) Whilst playing back samples on the external HD from a virtual instrument in Logic X, the computer completely froze and started to repeat about a 1/4th of a second loop of the material being played back. Complete freeze; nothing responding, only the looping clip of the playback.

    2.) Restarted the machine using Opt+Cmmd+Power button.

    3.) External HD didn’t mount yet could be seen in Disk Utility.

    4.) Ran “Verify Disk” and “Repair Disk” both unsuccessfully, and both stopped with a “The disk could not be repaired. You can read files but cannot write. Backup and reformat as soon as possible.”

    5.) After the first failed attempt at verifying the disk, the HD “mounted” but didn’t mount; the option to mount in Disk Utility remained (although trying to mount it prompted an error message) BUT HD could be seen on the desktop of the computer (did not appear in sidebar), and all the content could be accessed, copied to other volumes, but not written to.

    5.) After backing up some important work, “Got info” on the drive, and noticed that the usual permission alteration box was grayed out, and the words “You can only read” were inscribed above. Changing permissions the traditional way seemed like no option.

    6.) Used Disk Warrior to try and rebuild directory, permissions, do whatever DW does best. No luck: upon trying to implement the newly build directory, the entire computer kernel panicked. Black screen, then the grey screen of “You need to restart your computer. Press a key to continue” in several languages came up.

    - Launched DW again, and this time it immediately came back with an error regarding the drive and no option at all to even attempt a repair because of a hardware error. (My heart starts to sink... could this have been a hard crash? But if so, why could I still access the drive and why would it do this “fake mount”?)

    7.) Restarted the computer. Changed cables. Changed ports on the drive. Used USB rather then Firewire. Booted computer into Safe Mode, continued to restart things, tried running Disk Utility again. All peripherals detached. All other applications closed. No luck. More Disc Warrior. No luck.

    8.) Tried Drive Genius. Also had no luck and crashed before even getting significantly into repairing the drive. (Was even more useless then DW...)

    9.) Diagnostics of the drive returned normal results; they listed how many files, the format of the drive (HFS+, Mac OS extended journal) all sorts of details that indicated the drive might have a chance of living.

    10.) Prowled around online. Decided since nothing could change the state of the drive and that since the most important pieces of work had been copied elsewhere, launched Terminal. sudo and other commands proved useless stating that the drive is in “read only mode” and can not be changed. (“Excuse me...?”)

    11.) Tried more RANDOM terminal commands that I found online, all not making a dent into this drive. Nothing changed. At. All. Same effect from Disk Utility, Disk Warrior, everything. At this point I’d have been pleased if a sudo or fsck or chfg did some damage, but nothing I tried had any effect.

    So, this is where I’m at. A couple other notes:

    The drive indicator light blinks constantly when connected to the computer
    When the problem initially occurred, there might have been some kind of power fluctuation (I am in Southeast Asia after all) but I can’t confirm that because everything else that was connected to power didn’t flinch: lights in the room, TV, LED on the computer charger, etc. all remained nominal.
    I don’t suspect this could have been a problem of streaming audio from the disk and Time Machine firing up at the same time, because that’s happened quite a lot to me while running Logic and every time it’s simply stopped playback, or slowed playback.

    The only thing I have not done is reformat the drive because I don’t have enough space to backup the important files.

    Currently, I’m considering this as an option but I wanted to hear what experts thought of this situation:

    Reformat drive and then use data recovery to restore things like the virtual instrument sample libraries I use for work, and the iPhoto library (which cannot be duplicated).

    This sounds crazy even to me, and I’m sure it won’t work perfectly. Will probably lose a lot of data.

    So what do you think? Have I missed something here? What’s going on with this? Under what circumstances would it be impossible to bring an external hard drive out of a read-only state?

    Thanks for reading and for your time. Looking forward to your responses.


    Info: MacbookAir, 128GB SSD, OS X 10.8.5, 1.8 GHz i5, 4GB DDR3 RAM
    Drive: G-Drive 4TB (RAID capable, not implemented)
     
  2. Tumbleweed666, Jun 6, 2014
    Last edited: Jun 6, 2014

    Tumbleweed666 macrumors 68000

    Joined:
    Mar 20, 2009
    Location:
    Near London, UK.
    #2
    Either you want what data is left on there, or you dont.

    If you dont, by all means continue trying madcap solution's such as reformatting and then data recovery. Though if you dont want it, why go to the trouble, toss it.

    If you do want the data, buy another drive or two and copy whatever you can read off this bad drive which no doubt will soon become a read not at all drive, and toss it.
     
  3. velocityg4 macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #3
    The drive is dead. Get a good data recovery program like Stellar Phoenix and a new external to try and hopefully recover data to. If the data isn't worth that to you then throw it out.
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    Are you saying you are considering reformatting the drive in the hope that would help something like Disk Warrior be able to recover files? If that is what you are saying, don't do it. A reformat will only make data recovery more difficult.

    The bottom line is you have a failed drive here and you have already tried Disk Warrior and that is not working. Your next option is to pay a professional data restoration company to try and recover files, but it will not be cheap.

    If the data is important to you, spend the money for file recovery. Otherwise, it looks like you have done all you can and it is time to toss that drive in the trash.
     
  5. snogger thread starter macrumors newbie

    Joined:
    Feb 5, 2009
    Location:
    Seattle
    #5
    Thanks for everyones responses! Much appreciated.

    If I were in the states it'd be a no brainer to get another hard drive and migrate the data. When it started to fail I was in a very rural area of Thailand and couldn't easily get back to civilization to pick up some more drives. But, since it's important, I changed plans and got the next flight back to Bangkok where I got a few more drives and spread the media out onto them.

    Again, much thanks for the opinions and advice. Great forum here :)
     
  6. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #6
    Download DataRescue3 and "aim it" at the drive.
    (DR3 is a free download, and will run in "demo" mode and let you recover -one- file. This is for testing purposes to see if it will work for you BEFORE you pay the registration fee)

    Choose the "deep scan" option.

    What happens next?
     

Share This Page