F#!k.....just spent the past half day restoring from Apple Logo Screen of Death

Discussion in 'iPhone Tips, Help and Troubleshooting' started by diesel, Sep 1, 2008.

  1. diesel macrumors 6502a

    Joined:
    Aug 3, 2007
    #1
    I've read all of the reports from everyone else about the apple logo screen of death and felt bad for everyone and counted my lucky stars that it never happened to me. until last night........i installed a few apps, and deleted one, and i noticed my settings screen wouldn't come up. so i did a home/power reset and the screen was stuck on the apple logo, for 5 mins, then 10, then 20, then 30, and i was like great......crap, i think i just got hit by the ALSOD (apple logo screen of death). after reading through the great threads here and on the applue support forums on how to restore the phone (turn off the phone, then turn it back on and while holding down home, connect to itunes until prompted to restore). I did that, feeling comfortabe that i had a backup from only this past friday to restore to.

    well guess what..........when i selected that backup, itunes did it's thing for 15 minutes only to come back and tell me that the backup was "corrupted". I was like WTF!!! the only other backup that i had was from the conversion from the first gen iphone to this 3g iphone that was done on july 11. so i had to use that. i basically lost all my ewallet data......arghhhh!!........that really hurt. plus all my notes since july 11.

    i had to reinstall all my apps, music, reconfigure all settings, etc. etc. what a pain. i've read reports that the ALSOD could be caused by rebooting the iphone when you have too many apps loaded on the iphone and how something gets caught in some kind of endless loop, so to err on the side of caution and until firmware 2.1 comes out sometime later this month, i am now doing selective app syncs instead of sync all apps. i am keeping 20% of my apps off my iphone and probaby won't be installig any new apps without taking any off until the new firmware fixes this problem. as for the corrupt backup, i don't know wtf happened there and it really worries me. itunes never said i had a corrupt backup and there was no indication until i needed to depend on the backup. does anyone know what might cause a backup to be corrupt and is there any way of knowing if the backup is corrupt without actually using it to restore? because the backups have been ridiculously long.......about 4-5 hours for me, i've been mostly just clicking on the x thing to cancel the backup and bypass it and i suspect that i might have taken a backup on that day, which was not corrupt, then unplugged the phone from my computer and probably the same day replugged it in there and canceled the backup and that little piece of the backup that started before me canceling might have overwritten the previous good backup. could that have been the cause?

    what a freaking mess apple has created with this situation
     
  2. Insulin Junkie macrumors 65816

    Insulin Junkie

    Joined:
    May 5, 2008
    Location:
    Mainland Europe
    #2
    That definitely seems like a real bummer. That's the first time I've heard of this... now that I'm aware I'm gonna limit the number of apps on mine. Out of curiosity... how many apps did you have on yours?
     
  3. Excellerator macrumors 6502a

    Joined:
    Aug 3, 2008
    #3
    Thats what did it right there. When you delete an app on the iPhone, it takes forever to remove it (just like installing). So when the settings doesn't come up it is still removing the app. Everyone thinks its like a PC where you hit delete and its gone. Not true. Wait a while then the settings will be fine. When you reset the phone that messed it up to the ALOD (Apple Logo Of Death).
     
  4. diesel thread starter macrumors 6502a

    Joined:
    Aug 3, 2007
    #4

    about 70 apps. there's speculation that it's not purely the number of apps you have loaded but also the size of the apps is a factor as well. so the more space an app takes up, the more potential problem it could cause in combination with the other apps/sizes. I'm no hardware/software genius but I found this interesting post over at the apple forums from a jayberk over there:

    http://discussions.apple.com/thread.jspa?threadID=1676330&tstart=90


    "I found this on another message board.....

    I wanted to email this to someone from the iphone dev team for some feedback and discussion before posting but as I don't know how to contact them I'll post my findings to date here, and hopefully anyone else working on this problem can share their findings too.

    Until Apple fixes it properly, I think I have a workaround for the infamous "Hangs on Apple Logo after installing/updating apps and needs restore" and an explanation of the root cause.

    This is the problem where after a crash or restart during app install/update/uninstall the device will get stuck on the Apple (or pineapple ) boot screen and either spontaneously reboot after a while, or "freeze" requiring a two fingered reboot. On my ipod touch when this freeze occurs the display dims to half brightness and the unit is no longer pingable over wifi.

    Usually you get stuck in a loop where no amount of forcibly rebooting will recover the device and you have to restore.

    Here's the explanation: When the 3rd party application state changes, Springboard "regenerates the application map" which you can see clearly if you watch the system log with the iPhone Configuration Utility.

    (Available here: http://www.apple.com/downloads/macos...formacosx.html )

    This can take some time. The more and/or bigger applications you have installed, the longer this takes. This regeneration process happens ANY time a change to installed applications occurs.

    Here's the problem - Springboard is watched by a watchdog process which is handled by configd. The location of the watchdog and it's configuration files is /System/Library/SystemConfiguration/mobilewatchdog.bundle

    The watchdog constantly monitors Springboard, and if it doesn't respond at least once every 2 minutes, it is killed and forcibly restarted. If this happens approximately 4 times, the watchdog will attempt to reboot the device, but it usually just freezes the system with the half brightness apple logo.

    The problem occurs when the number and/or size of applications installed causes a regeneration of the application map to take longer than 2 minutes - it becomes impossible for Sprinboard to complete the task before it is forcibly killed by the watchdog. It will try again the next time and run out of time and be killed again. Hence stuck at the boot screen until doing a restore.

    It is unbelievable that Apple allowed this design flaw, yes design flaw, not bug go out into the wild and it still hasn't fixed it in 2.0.1. Clearly the watchdog arrangement was put in place before 3rd party application support, and none of the programmers considered the possibility of Springboard taking more than 2 minutes to regenerate the application map.

    So, how to recover from being stuck at the apple logo without doing a full restore wiping everything ? If you have openssh installed so you can log in remotely you can fix it quite easily, as you get nearly 2 minutes of ssh access during the apple logo before the system freezes where you can log in for "emergency surgery".

    If you don't have OpenSSH already installed then sorry, it's restore time...

    As the device is trying to boot up but still at the apple logo, try to log in as root using ssh. You should find you are able to log in soon after the device is pingable on your wifi network, and you have a few minutes to complete the following steps in time.

    For example from a mac, log in with:

    ssh -l root 192.168.1.103

    Where your iphone/ipods own ip address is substituted.

    First we will disable the watchdog timer (by temporarily moving its files elsewhere) and then reboot:

    mv /System/Library/SystemConfiguration/mobilewatchdog.bundle/ /
    reboot

    After a few seconds the device will start to reboot, and after approximately 3-6 minutes (depending on how many apps you have installed) you will reach the lock screen as normal, when that happens we now have to re-enable the watchdog timer, and reboot again, so again log in with ssh, and type:

    mv /mobilewatchdog.bundle /System/Library/SystemConfiguration/
    reboot

    You should find your iphone / ipod touch will reboot normally a second time.

    The reason this is a workaround is because you CAN'T leave the watchdog disabled, because as well as monitoring Springboard and killing/restarting it, the watchdog also has to periodically reset the HARDWARE watchdog, if this doesn't happen the device will spontaneously reboot. The hardware watchdog is 10 and a bit minutes, so without the watchdog installed and working your device will reboot itself every 10 minutes.

    If anyone knows how to contact or draw this message to the attention of the dev team I have an idea for a simple patch that they could apply to the watchdog as part of the Pwning process (or as a Cydia package) that would for all intents and purposes solve this problem until Apple gets around to fixing it properly. Please send me a PM.

    I see Firmware 2.0.2 has just come out so it is possible it has fixed this problem, but my gut feeling is that they probably haven't and I won't be trying 2.0.2 to find out until it is Pwnable

    Note: This same issue is the reason why after installing apps with Cydia the system will sometimes freeze. As far as I can tell Cydia is NOT to blame - what Cydia does is tells Springboard to regenerate the application map, and it is that application map regeneration that triggers the problem - Springboard becomes unresponsive for extended periods of time, the watchdog process starts trying to kill Springboard, and all **** breaks loose...this procedure will also recover from that situation.

    The reason Installer.app doesn't trigger this problem is it doesn't tell Springboard to regenerate the application map - it just kills Springboard and allows it to launch again."


    in case the above is true, i will be limited apps on my iphone until reports of these incidents go away, hopefully with the new upcoming 2.1 release
     
  5. diesel thread starter macrumors 6502a

    Joined:
    Aug 3, 2007
    #5

    thanks, that makes sense. crazy though that they would allow an uninstall to still continue with no prompt to the fact that such a critical task is ongoing when trying to restart the phone. if that is what is going on.

    i remember the settings not coming up before a while back and though i'm not clear on the timing, i do remember restarting the phone in order to get the setting to come up again. i can't remember if that was from an install or uninstall. to err on the side of caution and not to go through this restore ******** gain with backups that may or may not actually work, i will take anyone's tips on what to avoid and what not to do until 2.1 comes around.
     
  6. Excellerator macrumors 6502a

    Joined:
    Aug 3, 2008
    #6
    I did the same thing one night and had to restore. Another time the settings didn't come up and I thought, "NOT AGAIN!!" so I waited and noticed the little processing circle at the top come up a few minutes later and then the settings worked fine. Apparently, it will not bring up the settings when an app is installing/uninstalling.
     
  7. diesel thread starter macrumors 6502a

    Joined:
    Aug 3, 2007
    #7

    by the way does the asod apply to app installs as well? if you were to reboot in the middle of an install? i remember too many times to count that during the middle of an app install or right at the start of it, the iphone would spontaneously restart and you could see when it came up that the app was still installing. i might have even had that happen during uninstalls but can't remember specifics

    any thoughts on the possibility that # apps/size could cause a problem when restarting the phone?
     
  8. Excellerator macrumors 6502a

    Joined:
    Aug 3, 2008
    #8
    Not sure other than what I have read of the forums. I have about 6 pages of apps that don't work now. So I am going to try removing and reinstalling later.
     
  9. diesel thread starter macrumors 6502a

    Joined:
    Aug 3, 2007
    #9

    ouch, good luck excellerator!!!

    i think until the new firmware, i'm just going to be a heck of a lot more selective in what apps i buy/download, because i'm sure the install/uninstall process is one of possibly a few causes of this problem. i just can't go through this restore process again, especially when i can't count on the backup to work. not to mention if this was to happen when i'm away from my computer............or out and about, i need my iphone to be a phone first, mini computer second.
     
  10. dkeninitz macrumors regular

    Joined:
    Feb 16, 2003
    Location:
    Germantown, MD
    #10
    I've been through this process four times now; happens basically every other time I add a new app. The process for dealing with an iPhone in recovery mode isn't even documented at the Apple website, so the first time it happened I had to call them: I thought the phone had died permanently. Now that I know how to do it, I've done it three more times, but man is it tedious. It takes a considerable amount of time to get the memory reformatted, and that usually only starts after three or four false tries at getting iTunes to recognize the phone in recovery mode. Then you've got the whole restore process, followed by a fresh sync (as if the phone is being synced for the first time).

    Why can't Apple fix some of the relatively simple bugs on this thing, like this one and the bluetooth car pairing and echo problems. Apple may pick up the phone faster than Dell or Microsoft, but they are as arrogant a company as I've ever seen when it comes to fixing bugs. Mobile Me is another classic example.
     
  11. Excellerator macrumors 6502a

    Joined:
    Aug 3, 2008
    #11
    First I tried the not using Itunes - still crashed

    Then I tried using the AppStore on the phone only - still crashed

    Then the last time I tried not hooking to Itunes or using the AppStore - still crashed.

    I am now going back to Itunes 7.7.0 because a lot of people say the problem is with 7.7.1.

    See here: (Thanks Darkfiber)

    http://forums.macrumors.com/showpost.php?p=6055900&postcount=161
     
  12. Scott437 macrumors newbie

    Joined:
    Aug 27, 2008
    #12
    I'm in the middle of my 2nd 4 hour restore right now and all I can say is I hope that IF 2.10 is going to fix this issue Steve best not be holding on to the update till the "event" this month. The more I use this device the more it brings back memories of using an old palm device of mine. Limited software, crashes all the time and requires you to completely restore it every time it crashes.
     
  13. diesel thread starter macrumors 6502a

    Joined:
    Aug 3, 2007
    #13

    reminds me of pocket pc (prior to windows mobile) years and years ago, where a hard set would be required way to often due to crap application installs, and restoring from that was painful until i believe i bought a backup program from spb, and i could schedule backups that created a compressed self extracting file of your whole pocket pc that you could then just copy back to your computer. after a hard reset that erased all the data from your device and reset it back to factory settings, you could just copy the backup file back to the pocket pc device, double click on it and it would extract all the apps and data back to your pocket pc in only a few minutes. of course back then, we weren't dealing with gigabytes of data, but still, the ease of use was awesome. the best piece of software for pocket pc that i ever came across. i wish apple's backup process would be as simple and quick.
     
  14. diesel thread starter macrumors 6502a

    Joined:
    Aug 3, 2007
    #14
    By the way, if anyone has the ASOD, and prior to restoring, please give this a try as posted by Darwinian Dude in a comment to an article on the ASOD in Arstechnica:

    http://arstechnica.com/journals/app...apple-logo-screen-of-death-with-recovery-mode

    Apparently a few of the comments back is that this has worked for them and saved them from restoring the iphone. too bad i didn't come across this until i undertook my painful restore:


    "15-MIN SOLUTION: CONNECT TO ITUNES AND REBOOT 3 TIMES TO AVOID RESTORE
    So this has happened to me more times than i can count, and I've recovered both my phones (2G + 3G) using this method. I've seen some people in this thread allude to this solution but let me just spell it out completely and hopefully this will save you a few restores on your phone.

    1. Connect to iTunes via USB. Do not disconnect for rest of these steps. iTunes may appear frozen or stuck with spinning beachball....this is okay, do not Force Quit iTunes. I tried a few times w/o it being connected to iTunes and it doesn't work.
    2. Once connected, hold Home + Power until screen blinks then Apple logo comes back up.
    3. Wait until Apple logo dims slightly (~5 minutes or less). Do NOT reboot until the apple logo dims.
    4. Hold Home + Power again until it reboots and Apple logo comes back up.
    5. After 2 min or so, the phone may vibrate once or twice. Continue waiting for the full 5 min until Apple logo dims slightly. iTunes at this stage MAY recognize the phone...do not sync or do anything in iTunes.
    6. Hold Home + Power for the 3rd time until it reboots. Phone may vibrate again after 2 minutes or so. Eventually you'll break into your Home screen.
    Hope that helps and let me know if it does."


    If anyone does try this, can you please report back and let us all know if it worked for you? Thanks and good luck!!!
     

Share This Page