FaceTime over 4G now working for ATT iPhone 4S and older?

Discussion in 'iPhone' started by bradl, Sep 4, 2013.

  1. bradl macrumors 68040


    Jun 16, 2008
    I tried this 2 weeks ago, and thought it was a fluke, but tried it again last night, and it definitely worked.

    For all of you ATT iPhone 4S and older users, could you confirm that FaceTime over 3G or 4G works for you? All of a sudden, it does for me, though according to the Page 1 thread, this wasn't supposed to be available until the end of the year.

    Could someone else confirm that this does indeed work for you? It does now for me.

  2. richard6r macrumors regular

    Jun 11, 2013
    AT&T Recently enabled FaceTime for iPhones that support it over the cellular data connection so yes. There was an article about it a few months back. Looks like you missed the memo. :p
  3. bradl, Sep 4, 2013
    Last edited: Sep 4, 2013

    bradl thread starter macrumors 68040


    Jun 16, 2008
    Umm, no.. they enabled it for the iPhone 5, though the 4S and older weren't supposed to be enabled until 'by the end of the year'. We haven't reached that time yet.

    EDIT: The thread mentioning the timeframe is here: AT&T to Expand FaceTime Over Cellular to All Customers by Year End

    To further add to this, I'm on a grandfathered unlimited data plan, and am able to FaceTime over cellular. Can anyone else do the same (over cellular, with or without unlimited data)?

  4. Rayfire, Sep 4, 2013
    Last edited: Sep 5, 2013

    Rayfire macrumors 68030


    Aug 25, 2008
    My iPhone 4S can do Facetime now with AT&T on an old, unlimited 3G data plan.
  5. richard6r macrumors regular

    Jun 11, 2013
    My bad on assuming that all the iPhones gained that ability when they flipped the switch. Although tiered iPhone 4S customers had the ability themselves for the longest time.
  6. dave420 macrumors 65816

    Jun 15, 2010
    I just got the ability to do Facetime on the unlimited plan about a week or two ago with my 4S. I had been checking it frequently since I had heard the news a while back, but it wasn't enabled for me until recently.

Share This Page