FCP – How do I remove “jaggies” in post?

Discussion in 'Digital Video' started by Chris7, Jan 4, 2009.

  1. Chris7 macrumors 6502

    Joined:
    Aug 8, 2008
    Location:
    Lost in Thought
    #1
    I shot some clips with a HF-100 (1920 x1080, 60i) and made a quick SD DVD using the settings in Compressor suggested by Larry Jordan in the Lynda.com tutorials. I just had a chance to view them on a 50” screen and they’re not pretty. Among other things, the lines are extremely jagged, even when not panning. Surely there’s a way to smooth these out in FCP. Any help is much appreciated.

    Thanks,
    Chris
     
  2. DPA macrumors 65816

    DPA

    #2
    You are shooting interlaced footage, are these line what you are talking about? And what do you mean by jaggies?

    Since you have Final Cut Pro, you also have Final Cut Studio which includes Motion. Motion has a very good stabilizer. FCP does not have one at all because they expect you to be able to use the one in Motion. Here is a video the covers the stabilizer feature
     
  3. 4God macrumors 68020

    4God

    Joined:
    Apr 5, 2005
    Location:
    My Mac
    #3
    I think the OP is looking to deinterlace footage. ;)

    Compressor has this feature and Red Giant software's "Frames" and "Instant HD" have this as well.

    You can also export you sequence using the "Export Using Quicktime Conversion" option. There you can set to deinterlace original footage. Also, you
    should consider shooting 30f or 24f.
     
  4. DPA macrumors 65816

    DPA

    #4
    That's what I thought to. Just trying to make sure.:cool:;)
     
  5. 4God macrumors 68020

    4God

    Joined:
    Apr 5, 2005
    Location:
    My Mac
    #5
    Cool.

    Also, to the OP, I use this workflow (Compressor Version) for my HV30 (when shooting 24f). I think it should work the same for your camera since it also shoots 24f over 60i.
     
  6. DPA macrumors 65816

    DPA

    #6
    Good suggestion, I deinterlacing can be tricky depending on the footage and can leave you with poor results. I think googling this topic could help very much.

    Regards
    David
     
  7. LethalWolfe macrumors G3

    LethalWolfe

    Joined:
    Jan 11, 2002
    Location:
    Los Angeles
    #7
    You might have screwed up the Field Order someplace along the way. Any sort of resizing, vertical moving, speeding up/down and/or reversing of footage can foul up the field order. IIRC there is a field order conversion that happens in Compressor, which is another possible point of failure, and unnecessarily de-interlacing will also negatively impact the footage quality.


    Was the 50" TV HD or SD? SD on a 50" HDTV isn't going to be pretty no matter what you do.


    Lethal
     
  8. Chris7 thread starter macrumors 6502

    Joined:
    Aug 8, 2008
    Location:
    Lost in Thought
    #8
    Thanks to all who posted. I think the problem is the camera. What I really want is to find a way in post to make a consumer camera look as close to possible to pro-sumer camera. I'm not sure this can be done. After I posted, I called FCP tech support, and the tech suggested trying a blur filter and a maybe a sharpen filter. I'm pretty new to FCS, and I've not tried this kind of thing before -- suggestions?
    I just made another short sample SD DVD, combining the same AVCHD (to AIC) footage with some professional HDV footage from a training book, and compressed it into MPEG-2. Both the HDV and AVCHD use upper field dominance, and I just dropped the clips in without modification, but I'll check compression settings to make sure I didn't screw up the field order settings there. So far I've just watched it with my computer DVD Player (which does not show the interlace), but the HDV footage already looks a lot better than my AVCHD. The TV I watched on was 50” 1080, fed by SD DVD. Won’t have access to that until next weekend, but I can watch on a smaller 1080 TV this eve.
    I actually was not wanting to de-interlace this footage, but I will want to de-interlace in the future, and I hear FCS does not have a very good de-interlacer, so I appropriate the suggestions.
    I also will surely be working with HDV into 24P sometime, so thins for the link to the workflow for this.
    I checked out the Motion video, but I could not find any discussion on the SmoothCam and Image stabilization features. I thought this was primarily correcting shaky images rather than smoothing jagged lines, but I'm interested on how you think it will help here.
     
  9. DPA macrumors 65816

    DPA

    #9
    Since you said:
    I thought the footage was also unstable and suggest that. It won't help the interlaced lines though.:(

    Regards,
    David
     
  10. sady symptom macrumors newbie

    Joined:
    Mar 12, 2009
    #10
    FIXING THE "JAGGIES" or Field Doubling

    Hey. Try setting your codec to pro res 422 (this solves alot of wierd problems). Also in the video processing tab under sequence settings set motion filtering to best. I find this works for me very nicely.

    Also, if you are editing HD footage in an SD timeline your HD footage should have a "shift fields filter +1." And if you are editing SD footage in an HD timeline your SD Footage should have a shift fields filter -1.

    Also last one. Slow motion HD in a SD Timeline requires both a shift fields filter +1 & deinterlacing. Sometimes this does not work though & you might have to resort to adding a small amount of motion blur.

    Toodles!
     
  11. huntercr macrumors 65816

    Joined:
    Jun 6, 2006
    #11
    This thread might help... ( but honestly, I have no idea I just searched around for someone having what seemed to be a similar problem )

    Hope this helps!

    EDIT: weird... this thread showed it had no posts when I clicked on it and now there's a bunch from months ago. DOH!
     

Share This Page