Fell way behind on updates, how should I update and unlock a 4.0.1 with 1.59.00?

Discussion in 'Jailbreaks and iOS Hacks' started by sasxempire, Oct 25, 2011.

  1. sasxempire macrumors newbie

    Joined:
    Jan 16, 2008
    #1
    My version is 4.0.1 and my baseband is 1.59.00. I use to jailbreak all the time and be up to date with everything, at least until I got my iPhone 4. So it's unlocked and Jailbroken right now and the firmware is saved in Cydia, but I am lost on how to update to the latest, untethered, unlockable version. Any ideas?:)
     
  2. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #2
    The latest untethered jailbreak on Iphone 4 is 4.3.3 and if you have SHSH blobs save, you can create customs firmware of 4.3.3 and upgrade to that. OS5 is tethered jailbreak for now.
     
  3. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #3
    Latest untethered is 4.3.3
    Look on the top of cydia to make sure you have shsh's for that version.
     
  4. sasxempire thread starter macrumors newbie

    Joined:
    Jan 16, 2008
    #4
    Alright, so if I have this right,

    1. Get TinyUmbrella and make sure the shsh blobs are correct.
    2. Download IPSW 4.3.3
    3. Download PwnageTool and create a custom IPSW.
    4. Restore with that IPSW

    Do I place Saurik's server into my host file?

    Am I missing any steps? Anything important I should note when doing this to preserve my baseband?
     
  5. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #5
    No, TU does the host editing for ya.
    Make sure you do have 4.3.3 blobs though cause if you don't then it will not let you.
     
  6. murdercitydevil macrumors 68000

    murdercitydevil

    Joined:
    Feb 23, 2010
    Location:
    california
    #6
    Just FYI, running 1.59 baseband on FW 4.3 and higher will result in a cosmetic bug where it always displays 1 signal bar, regardless of actual signal. AFAIK it still hasn't been fixed with ultrasn0w.
     
  7. VeeGee90 macrumors member

    VeeGee90

    Joined:
    Jul 17, 2010
    Location:
    Groningen, Netherlands
    #7
    From what I believe Ultrasn0w has been fixed for versions above 4.3.3, FAFAIK it works fine on iOS 5.0.

    I'm actually in the exact same situation as you are, iPhone 4, 1.59.00 baseband and running 4.0.1. It's running perfectly fine but I would like the new features of iOS 5. Prolly gonna upgrade my phone tomorrow, and hopefully it is stable, as I rely on the Ultrasn0w unlock.
     
  8. mrCide macrumors member

    Joined:
    Jul 27, 2009
    #8
    Do you have a link or something to show that ultrasnow is fixed with versions above 4.2.1 w/ 1.59.00 bb? From what I personally read signal bar, voicemail, and mms are still erratic and broken for some people, and this was in the last week.
     
  9. bobsegal macrumors newbie

    Joined:
    Jul 24, 2007
    Location:
    Orlando, FL
    #9
    Did this update to iPhone 4 same config worked

    I upgraded iPhone 4 10/24/2011 with 1.59.00 to 4.3.3 and ran the current ultrasnow and have not problems all bars show. I followed that process that is stated in this post.
    :)
     
  10. VeeGee90 macrumors member

    VeeGee90

    Joined:
    Jul 17, 2010
    Location:
    Groningen, Netherlands
    #10
    Just go to the dev-team blog, and read the new post about Ultrasn0w.
     
  11. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #11
    Hmm, if ultrasnow on iOS 5 is working correctly, that just means I need to wait for an untethered JB.
     
  12. VeeGee90 macrumors member

    VeeGee90

    Joined:
    Jul 17, 2010
    Location:
    Groningen, Netherlands
    #12
    You can also just jb tethered and upgrade to untethered when released :), at least, thats what I'm planning to do.
     
  13. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #13
    If that option is available and doesnt need a restore to use the untethered JB.
     
  14. VeeGee90 macrumors member

    VeeGee90

    Joined:
    Jul 17, 2010
    Location:
    Groningen, Netherlands
    #14
    Well, thats just a matter of time, but I don't mind to restore again when the untether comes out (IF that is the right way, and I think it will just be a matter of running redsn0w once more).
     
  15. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #15
    I don't like tethered JB for a phone. I'll probably do it for my iPad, but not my only phone source. If I've waited this long to upgrade, then waiting longer for an untethered JB won't kill me. :D
     
  16. VeeGee90 macrumors member

    VeeGee90

    Joined:
    Jul 17, 2010
    Location:
    Groningen, Netherlands
    #16
    Gotta agree with you on that one, but I just can't wait to use the iOS 5 features, as I'm still on 4.0.1. I hope untether comes soon, else I'll just use the tethered.
     
  17. steven5210 macrumors member

    Joined:
    May 20, 2011
    #17
    That's weird unless you upgraded your baseband I don't know how you don't have the problem. Because my Iphone 4 on 2.10.04 BB is on ios 5 but from a custom preserved firmware only has the 1 signal bar cosmetic glitch.
     
  18. VeeGee90 macrumors member

    VeeGee90

    Joined:
    Jul 17, 2010
    Location:
    Groningen, Netherlands
    #18
    For as far as I know that baseband is not supported by Ultrasn0w. Ultrasn0w is supposed to work just fine with the 1.59.00 baseband I believe.
     

Share This Page