File permission of "-rwxr-xr-x@" making application impossible to read the file?

Discussion in 'macOS' started by Simplicated, Dec 30, 2009.

  1. Simplicated macrumors 65816

    Simplicated

    Joined:
    Sep 20, 2008
    Location:
    Waterloo, Ontario, Canada
    #1
    Hello,

    I have two batches of videos.

    The first batch of videos was copied to an external drive from a Windows PC with MacDrive installed. When I came back to my Mac, I plugged the external drive into my Mac and moved those files to my hard drive.

    The second batch was copied using Connect to Server command right from my Mac.

    The funny thing is Final Cut Pro cannot recognize the first batch of videos.

    So I took a look at the file permissions using Terminal. All of the videos in the first batch have a file permission of -rwxr-xr-x@ but the others have -rwxr-xr-x. I tried to do a chmod 755 on every video file, but the @ sign still wouldn't go away.

    I hope my explanation was clear. Please help me with this. Thank you very much. :)
     
  2. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #2
    What do you get if you type

    ls -@l

    (in Terminal) from the directory that contains the video files?
     
  3. Simplicated thread starter macrumors 65816

    Simplicated

    Joined:
    Sep 20, 2008
    Location:
    Waterloo, Ontario, Canada
    #3
    Hi,

    This command lists out all the files I have and their permissions.

    Videos having permission of -rwxr-xr-x@ also have an additional line of
    Code:
    com.apple.FinderInfo	        32
    Thanks for your help :)
     
  4. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #4
    I was wondering who was listed as owner. Could you copy and post the output from ls -@l
     
  5. Simplicated thread starter macrumors 65816

    Simplicated

    Joined:
    Sep 20, 2008
    Location:
    Waterloo, Ontario, Canada
    #5
    This is the output. dave is my Home folder name.

    Code:
    total 89595816
    -rwxr-xr-x@ 1 dave  staff  4195065228 Dec 28 20:51 BS_Chloe_Meeting1.avi
    	com.apple.FinderInfo	        32 
    -rwxr-xr-x@ 1 dave  staff   549224788 Dec 30 18:49 BS_Chloe_Meeting2.avi
    	com.apple.FinderInfo	        32 
    -rwxr-xr-x@ 1 dave  staff  1339331032 Dec 28 22:35 BS_Chloe_Meeting3.avi
    	com.apple.FinderInfo	        32 
    -rwxr-xr-x@ 1 dave  staff  2052211136 Dec 28 22:37 BS_Dave_Meeting1.avi
    	com.apple.FinderInfo	        32 
    -rwxr-xr-x@ 1 dave  staff   941065032 Dec 28 22:40 BS_Dave_Meeting2.avi
    	com.apple.FinderInfo	        32 
    -rwxr-xr-x@ 1 dave  staff  1587959132 Dec 28 22:45 BS_Dave_Meeting3.avi
    	com.apple.FinderInfo	        32 
    -rwxr-xr-x@ 1 dave  staff  1400276776 Dec 28 22:46 BS_Dave_Meeting4.avi
    	com.apple.FinderInfo	        32 
    -rwxr-xr-x@ 1 dave  staff  2474205612 Dec 28 22:48 BS_Dave_Meeting5.avi
    	com.apple.FinderInfo	        32 
    -rwxr-xr-x@ 1 dave  staff  1441174728 Dec 28 22:50 BS_Dave_Meeting6.avi
    	com.apple.FinderInfo	        32
    -rwxr-xr-x  1 dave  staff  4194721004 Dec 30 18:55 FP_Walking1.avi
    -rwxr-xr-x  1 dave  staff  1404446400 Dec 30 18:57 FP_Walking2.avi
    -rwxr-xr-x  1 dave  staff  2258540376 Dec 26 03:49 HS_Explosion1.avi
    -rwxr-xr-x  1 dave  staff  2822868196 Dec 26 23:37 HS_Explosion2.avi
    -rwxr-xr-x  1 dave  staff  4194704172 Dec 26 23:41 HS_Explosion3.avi
    -rwxr-xr-x  1 dave  staff  4195214044 Dec 26 23:45 HS_Explosion4.avi
    -rwxr-xr-x  1 dave  staff   876370852 Dec 26 23:59 HS_Explosion5.avi
    -rwxr-xr-x  1 dave  staff  4190560408 Dec 26 23:58 HS_Explosion6.avi
    -rwxr-xr-x  1 dave  staff   928033416 Dec 26 23:46 WS_Explosion1.avi
    -rwxr-xr-x  1 dave  staff  4194634580 Dec 27 00:05 WS_Explosion2.avi
    -rwxr-xr-x  1 dave  staff   632405884 Dec 26 23:53 WS_Explosion3.avi
    Once again, thanks for your help!
     
  6. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #6
    Try this:

    On your Desktop, use Finder to make an empty new folder, and name it Foo.

    While holding the option key, drag the video files into the Foo folder. This copies rather than just moves the files.

    Then, in Terminal, enter the following lines, one at a time:

    cd ~/Desktop

    cp -XR Foo NewFoo

    cd NewFoo

    ls -@l

    Are the @ signs gone? Can you open the files now?
     
  7. Simplicated thread starter macrumors 65816

    Simplicated

    Joined:
    Sep 20, 2008
    Location:
    Waterloo, Ontario, Canada
    #7
    I can't think of a way to express my sincerest appreciation. It worked!! Thanks very much! :D
     
  8. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #8
    I'm not sure why it did, but I'm glad. You're welcome.
     

Share This Page