Resolved Files or Folders with Non-U.S. filename characters are not shown under OS X

Discussion in 'macOS' started by Thom75, Oct 23, 2014.

  1. Thom75, Oct 23, 2014
    Last edited: Oct 27, 2014

    Thom75 macrumors newbie

    Thom75

    Joined:
    Oct 23, 2014
    Location:
    Aylesbury, UK
    #1
    Hello Everyone,

    This is my first post so I would like to say hello before I continue.

    I'm trying for longer period of time copy files from my Windows 7 disk to OS X disk with no success. Google giving me no answer at all, so I've decided to ask here.

    Whether disk is formatted with NTFS or extFAT file system problem remain the same, files are not seen on OS X site but on Windows 7/Bootcamp are. Under Windows I can access them copy, delete, rename as normal but under OS X there are not visible. I've found that those files contain Non-U.S. characters in names, most of them are with Polish characters but I've found German and French too.

    When I trying copy them using Midnight Commander (installed from Home Brew) I can see those files but they file name is displayed in red and size is 0 bytes. Other files are visible normally.

    I've tried copy those files over the SMB network from Windows 7 PC but I getting information “file not found” or “file not exist” - I can't remember right now.

    I've tried on both Mavericks & Yosemite as well as NTFS read only build in driver and third party RW driver installed.

    Setting OS X to PL language not helping at all so even I've tried to rename those files but I can't find any working tool. One I've found replacing only first found letter besides this is not any good solution.

    Does Anyone have idea how to solve this problem?

    Kind Regards
    Thom
     
  2. Thom75 thread starter macrumors newbie

    Thom75

    Joined:
    Oct 23, 2014
    Location:
    Aylesbury, UK
    #2
    I've found workaround how to copy files

    I've found workaround how to copy files but it takes twice or more time than copy files directly and required a lot of manual work.
    Problem comes with file name encoding witch would be UTF-8.

    I've discovered accidentally trying to compress files using Total Commander's build in zip compression that it's asking whether I would like to store files with UTF-8 encoding as files in a folder got not standard characters or other way. Rest files/folders where Total Commander didn't ask for encoding was copied as normal. That works! I got all files copied to OS X site.

    BTW. Zip compression level I've used was set to 0. I've tried tar but it reports a lot of read files problems witch zip doesn't.

    I hope someone else will find that method useful.

    Thom
     
  3. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #3
    NFD: normalization=formD (normalisation form D)

    I'm glad that you found the cause of the problem.

    Also worth noting: normalisation.

    With ZFS on OS X, for example:

    Code:
    sh-3.2$ zfs get utf8only,normalization gjp22
    NAME   PROPERTY       VALUE          SOURCE
    gjp22  utf8only       on             -
    gjp22  normalization  formD          -
    sh-3.2$ 
    From an archive of the ZEVO support forum, originally posted in October 2012:

    http://www.ustream.tv/recorded/25862520 around 00:10:33 on the timeline:

    – Don Brady, amongst panel members at the 2012 Illumos ZFS Day.​

    From a July 2013 topic:

    Compatibility with other ZFS systems: NFD

    I asked in irc://chat.freenode.net/#zfsonlinux

    >> Is any Linux distro (or other ZFS-cabable OS) likely to have difficulty with ZFS file systems that use normalization=formD (normalisation form D)?

    Richard Yao responded:

    > I use normalization=formD on Gentoo (and include it in my zfs-install notes). I do not have any issues and no one has reported issues.

    https://github.com/ryao/zfs-overlay/blob/master/zfs-install
     

Share This Page