Firefox 13: Is there a way to disable the now automatic refresh of tabs.

doxavita

macrumors 6502a
Original poster
Jul 6, 2010
611
2
I just updated to Firefox version 13.

I always have a ton of tabs open at once, but it seems that now, each time I click one it automatically refreshes itself. Anybody know how to stop this "auto-refresh"?

EDIT: Or maybe it's not a "refresh" but simply: http://www.mozilla.org/en-US/firefox/13.0/releasenotes/ "Restored background tabs are not loaded by default for faster startup" , is that it? can I still disable this though?
 
Last edited:

oviddawen

macrumors newbie
Jun 6, 2012
2
0
1. Load about:config in the Firefox address bar.

2. Search for "BackgroundTabs" in the field provided. Firefox should return a line that looks like:

browser.zoom.updateBackgroundTabs ... true​

3. Double-click that line and confirm that the setting changes to:

browser.zoom.updateBackgroundTabs ... false​

4. Done!

----------

Actually, toggling that setting -- whether "true" or "false" -- seems to have had no effect. Sorry for the confusion.

1. Load about:config in the Firefox address bar.

2. Search for "BackgroundTabs" in the field provided. Firefox should return a line that looks like:

browser.zoom.updateBackgroundTabs ... true​

3. Double-click that line and confirm that the setting changes to:

browser.zoom.updateBackgroundTabs ... false​

4. Done!
 

doxavita

macrumors 6502a
Original poster
Jul 6, 2010
611
2
1. Load about:config in the Firefox address bar.

2. Search for "BackgroundTabs" in the field provided. Firefox should return a line that looks like:

browser.zoom.updateBackgroundTabs ... true​

3. Double-click that line and confirm that the setting changes to:

browser.zoom.updateBackgroundTabs ... false​

4. Done!

----------

Actually, toggling that setting -- whether "true" or "false" -- seems to have had no effect. Sorry for the confusion.

I was just about to post that, no solution whatsoever.

a. No damage done by toggling that, right?,
b. Does doing that void "my warranty", please tell me more, everything is still alright?
 
Last edited:

doxavita

macrumors 6502a
Original poster
Jul 6, 2010
611
2
Yeah, bummer that it didn't actually work as I'd thought. But no damage done in toggling the setting. And Firefox has no warranty, so nothing to void there. :)
So that "This might void your warranty" message when going into about:config, is simply a joke? :D ( I'll still be able to update my Firefox? )


Hope they fix this issue in a future release.
 
Last edited:

Watabou

macrumors 68040
Feb 10, 2008
3,414
691
United States
So that "This might void your warranty" message when going into about:config, is simply a joke? ( I'll still be able to update my Firefox? )


Hope they fix this issue in a future release.
It's actually a feature designed to make Firefox's startup faster by only loading the pinned tabs and the tab you were on. That way, the memory taken up is much lower and the start up is quicker.

To disable this, just to go Firefox preferences and select "Tabs" and deselect the "Don't load tabs until selected" option.
 

doxavita

macrumors 6502a
Original poster
Jul 6, 2010
611
2
To disable this, just to go Firefox preferences and select "Tabs" and deselect the "Don't load tabs until selected" option.
Well, I don't have the "Don't load tabs until selected" option. Perhaps because I'm a Tab Mix Plus user? , what can I do? this non-loading of tabs is getting really annoying for me...

EDIT: Found: How to fix this issue it seems it's all good now... :)
 
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.