Firewire Went Bye-Bye

Discussion in 'General Mac Discussion' started by Horrortaxi, Mar 11, 2004.

  1. Horrortaxi macrumors 68020


    Jul 6, 2003
    Los Angeles
    Last night I tried to access my (46GB) iTunes library, which is on a firewire drive connected to my Dual 1ghz MDD. I couldn't access any songs, and when I tried to go to the iTunes folder it showed as empty--although the drive didn't have enough free space so I knew the music had to be there. I plugged the drive into my cube and everything worked well. I zapped the pram and reset firmware on my MDD, then reconnected the drive. It mounted and I could use it normally. Today I tried to copy some files off of it and I got a message about not properly disconnecting the device--then the drive unmounted. Again, it worked on the cube. I plugged my iPod into the MDD and it didn't mount. I plugged my iSight in and it wouldn't work. I unplugged everything, zapped pram and firmware again, and now it all works. I'm copying my iTunes library to another drive and I'm wondering exactly wtf is going on.

    Oh yeah, a few days ago while I was accessing the external drive I got a kernel panic. They happen so rarely I can't believe I forgot about it.

    So either the firewire on the computer is messed up, or the drive is and it's causing problems. Any ideas? I'm running 10.3.2 and the drive is a Western Digital 80GB.
  2. jimsowden macrumors 68000


    Sep 6, 2003
    ° boot the mac in Open Firmware by holding [Apple key] [O] [F] after the startup chime.
    2° you'll get to a command prompt. the keyboard mapping will be QWERTY, so pay attention when you type the following :
    RESET-NVRAM (enter)
    RESET-ALL (enter)
    3° Now the mac should restart itself and the port should function properly again.
    If it still doesn't work, then it means that the PHY is damaged.
    Try zeroing out both drives (disk utility (backup of course)) If thats not it, you can dog my cat.
  3. Rower_CPU Moderator emeritus


    Oct 5, 2001
    San Diego, CA
    Some other advice from the Apple forums is to reset the PMU and PRAM.

    I've got an issue with my MDD at work with bus-powered firewire devices. iSight and DV cams work fine, but if I connect an iPod or pocket firewire drive the whole thing crashes. Did it on 10.2 and it's still doing it on 10.3.

    I'll be troubleshooting tomorrow and I'll try the OF resetting, too.

    I've got APP, so I can hopefully finally get this sorted out soon. :)
  4. Horrortaxi thread starter macrumors 68020


    Jul 6, 2003
    Los Angeles
    I haven't hit the PMU, but I have done the open firmware and pram. It's what got me going again last night but the drive later malfunctioned. I'm actually zeroing it right now. What did you mean by zero "both drives?" Both firewire drives?

    What's PHY?

    Looks like everything is going to be okay.
  5. big macrumors 65816


    Feb 20, 2002
    Man.. if that works.. I may try it, but I have seen this as a firewire issue, as most people with non-mounting iPods can mount theirs in USB.....

Share This Page