First Aid hosed a USB. Looking for options

reason4yourself

macrumors newbie
Original poster
Jun 14, 2017
2
0
32 gb Datatraveler USB. Had intermittent issues reading it. Finally got the stick to read and I began copying 18gb of data from it. Unfortunately, a handful of files spread throughout the folders kept causing copy failures. I'm talking about disconnect and re-insert the usb type copy failures (the failures made the drive disappear each time from finder). Up to this point get info accurately showed 18gb used of the 32.

In an effort to speed up the copy process, I made things worse. I ran disk utility and first aid. First aid popped up a brief message having to do with the stick's boot record I believe. I thought nothing of it. Continued and it "completed successfully". Only, it didn't. First aid managed to hose the usb. From that point forward it was unreadable by the OS (that's the message that pops up now). And it shows a full 32gb "used".

I ran Disk Drill and the files are still there. All 18gb of them. Unfortunately apps like DD recover the files without their names or original taxonomy....which is all but useless when you're dealing with tens of thousands of files.

Anyone aware of other data recovery methods/apps to recover these files in their original folder structure with their original names? Any guidance would be appreciated.

And no, she apparently never made a backup copy of the usb so her life's work is sitting on it inaccessible. Stories like this never cease to amaze me. I just hope I can recover her work. I'll lecture about backups later. ;-)