Fluid Still Relevant...

Dronecatcher

macrumors 68040
Original poster
Jun 17, 2014
3,673
3,514
Lincolnshire, UK
Quick FYI - on my Powerbook TenFiveTube is no longer working for most videos I browse to and although my preferred Youtube app is SMTube, it's always good to have other options. So, Fluid to the rescue again with a Leopard Webkit linked app using an iPhone 7 UA:

Mozilla/5.0 (iPhone; CPU iPhone OS 10_2_1 like Mac OS X) AppleWebKit/602.4.6 (KHTML, like Gecko) Version/10.0 Mobile/14D27 Safari/602.1

This plays 360P with ease but can also be dialled back to 240P too.

And another win for Fluid - on my Intel Macs there is no way to fully reach Instagram ie retain video playback but with Fluid on Leopard and again, an iPhone 7 UA it works fine...

Fluid.jpg
 

iluvmacs99

macrumors 6502
Apr 9, 2019
487
313
I've tried a few that TFT wouldn't play and they work fine. There is some weirdness going on with Youtube at moment - I've even had Safari on Tiger being able to play some videos!
The reason for the weirdness is due to the fact that Youtube now forces video streaming to standard def to manage bandwidth issues people are having when everyone is staying home streaming due to the Covid 19 issue.
 

Dronecatcher

macrumors 68040
Original poster
Jun 17, 2014
3,673
3,514
Lincolnshire, UK
The reason for the weirdness is due to the fact that Youtube now forces video streaming to standard def to manage bandwidth issues people are having when everyone is staying home streaming due to the Covid 19 issue.
I don't think that's the reason. This only works with one specific UA and furthermore if you bookmark a video that plays, it won't play from the bookmark, only from searching for it again. I've checked against youtube-dl and the videos that do play are presented in the same formats as those that don't..to further mix it up the age of the video isn't relevant either!
 

eyoungren

macrumors Core
Aug 31, 2011
21,946
14,577
ten-zero-eleven-zero-zero by zero-two
It's good to see Fluid is still performing. I still use it too, usually with a late OS X and Chrome UA, but I may start using mobile device UAs.

Anyway, finding that app was a trial so many years ago. When 1.0 was released Fluid wiped out all mentions of the betas and of course 1.0 and above are Intel only. I cannot for the life of me recall where I got it but I bet the source is long gone now.
 
  • Like
Reactions: Dronecatcher

iluvmacs99

macrumors 6502
Apr 9, 2019
487
313
I don't think that's the reason. This only works with one specific UA and furthermore if you bookmark a video that plays, it won't play from the bookmark, only from searching for it again. I've checked against youtube-dl and the videos that do play are presented in the same formats as those that don't..to further mix it up the age of the video isn't relevant either!
Good point. I will try yours again later and see whats up.
 

Dronecatcher

macrumors 68040
Original poster
Jun 17, 2014
3,673
3,514
Lincolnshire, UK
Good point. I will try yours again later and see whats up.
Just to be clear, my reply you quoted was about Safari on Tiger, not the Fluid app.
On Tiger, this is the UA that produces sporadic results:

com.google.android.youtube/5.3.32 (Linux; U; Android 4.0.3; ro_RO; GOCLEVER NETBOOK R103 Build/IML74K) gzip

Like so...

Safari.jpg
 
Last edited:

iluvmacs99

macrumors 6502
Apr 9, 2019
487
313
Just to be clear, my reply you quoted was about Safari on Tiger, not the Fluid app.
On Tiger, this is the UA that produces sporadic results:

com.google.android.youtube/5.3.32 (Linux; U; Android 4.0.3; ro_RO; GOCLEVER NETBOOK R103 Build/IML74K) gzip

Like so...

View attachment 904283
Right and since I have the same Powerbook G4 as yours, I see if I can duplicate it here with Safari.
 
  • Like
Reactions: alex_free

Dronecatcher

macrumors 68040
Original poster
Jun 17, 2014
3,673
3,514
Lincolnshire, UK
Last edited:
  • Like
Reactions: alex_free

PowerPC Punk

macrumors newbie
May 22, 2020
4
0
According to Dronecatchers advice:


i "Fluided" a Leopard Webkit linked app using an iPhone 7 UA:

Mozilla/5.0 (iPhone; CPU iPhone OS 10_2_1 like Mac OS X) AppleWebKit/602.4.6 (KHTML, like Gecko) Version/10.0 Mobile/14D27 Safari/602.1

It starts up real fast, but the main video window is black.
And somebody(?) tells me that my Browser is outdated.

???
 

PowerPC Punk

macrumors newbie
May 22, 2020
4
0
Did you run the scripts that came with the LWK bundle?

EDIT: Just tested and all working fine for me.

ahoi!
Scripts ? i just dropped Fluid into the Relink against Leopard WebKit script,
then "made" the Fluid-Youtube app, which caused the Browser is outdated blaba.
2.try: i made the Fluid-Youtube app, relinked it, now the Browser isn´t outdated
anymore, but still main video window is black.
???
Looking at this, when i got time. Fanx so far.
PowerPC Punk
 

wicknix

macrumors 6502a
Jun 4, 2017
970
1,690
Wisconsin, USA
Inside the LWK.dmg are scripts to update certificates, etc. Run those. Also make sure you install QuickTime 7.7. Once that's done, recreate your fluid app and relink it. (don't relink the fluid.app itself, relink the app you "made" with fluid)

Edit: If all you want to do is YouTube, TenFiveTube has been updated (since the original post), and now works again.

Cheers
 
Last edited:
  • Love
Reactions: G4fanboy

PowerPC Punk

macrumors newbie
May 22, 2020
4
0
ahoi!
shure i run those scripts, long time ago, the only thing i did not
was to install QuickTime 7.7, after reading this:
---
Unable to play certain movies!
Several people have been getting the message "An invalid public movie atom was found in the movie" when playing back in QuickTime Player. Final Cut Pro will either crash or display a white screen.
The recommended solution is to downgrade QuickTime or restore an earlier version of your system from a backup or clone.
---
"Never touch a runing system"! :)
Strange thing is that LeopardWK (604xx) is working well with QuickTime 7.6.9
???
Fanx, i always use Yewtube, works fine.
 

PowerPC Punk

macrumors newbie
May 22, 2020
4
0
And now i´m playing around with IceWeaselPPC.
What the f..k is this, like TFF on speed!
And even yutube works...
Now i play around with about:config!
And may trash it all, cool...
Fanx again.

wicknix rules o.k.

about:config! is beautiful, except:

extensions.getAddons.cache.enabled = true

i set it to false

This sends an update of metadata to Mozilla with a list of your Add-ons.
Just another data mining from Mozilla, we don´t need.

Skål
 

Dronecatcher

macrumors 68040
Original poster
Jun 17, 2014
3,673
3,514
Lincolnshire, UK
shure i run those scripts, long time ago, the only thing i did not
was to install QuickTime 7.7, after reading this:
Couple of things - there's no reason to use QuickTime as a videoplayer - VLC, MPlayer, Coreplayer and other do a far better job.
Whilst Youtube might still work with an earlier version, 7.7 makes the job more efficient but you'll only really notice on single G4s.
 

Similar threads

Replies
406
Views
16K
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.