iPhone Force iPhone to send as MMS instead of SMS?

IFRIT

macrumors 6502a
Oct 15, 2012
840
131
I think I can help, as a friend discovered this by accident and ended up racking a big MMS bill before he realised..

Under settings -> Messages, turn on "show subject field".

If you then use that subject field when sending a message to a non-iPhone, it will send as mms regardless of content - because SMS doesn't support the subject line. Obviously if you leave it blank, it'll just go SMS as normal.

Of course the real answer is just to get better friends and carry on using iMessage. And for the record I've never heard of the iPhone SMS issue you describe - don't forget your carrier has a part to play in that and it might be worth checking with them before you place it all at the iPhone's door.
The character limit on a single SMS is standard thing.
 

demo-ray

macrumors newbie
Jun 16, 2017
1
0
I think I can help, as a friend discovered this by accident and ended up racking a big MMS bill before he realised..

Under settings -> Messages, turn on "show subject field".

If you then use that subject field when sending a message to a non-iPhone, it will send as mms regardless of content - because SMS doesn't support the subject line. Obviously if you leave it blank, it'll just go SMS as normal.

Of course the real answer is just to get better friends and carry on using iMessage. And for the record I've never heard of the iPhone SMS issue you describe - don't forget your carrier has a part to play in that and it might be worth checking with them before you place it all at the iPhone's door.
Best solution I've found!
I've found countless suggestions online about how to force a text to become an MMS message. Your solution is simple and elegant, and it actually works! Thank you Dented.