FW ports on dual 1.8 messed up

Discussion in 'Macintosh Computers' started by letterbox, Jul 28, 2004.

  1. letterbox macrumors regular

    Apr 13, 2004
    My iPod will not mount on my G5 anymore, nor will it detect my mini dv camera. I just got a 20" cinema display, I'm not sure if that would have anything to do with it (it shouldn't at any rate).

    Any suggestions?

    The iPod will charge via FW but I don't have access to it. I ran HW diagnostic test and everything turned up fine.

  2. wrldwzrd89 macrumors G5


    Jun 6, 2003
    Solon, OH
    Have you installed Mac OS X 10.3.4?
    Have you repaired permissions recently?
    Another thing to try if that doesn't work is to reinstall Mac OS X.
  3. lisius_kent macrumors member

    Jul 10, 2004
    Bend, Oregon
    system profiler

    Is it showin in system profiler.
  4. mslifkin macrumors regular


    May 14, 2004
    New Jersey
    The display has a FireWire hub in it. Try disconnecting the display from your G5's FireWire port, and see if the G5 sees your iPod. If that works you can try reconnecting the FW hub in your display, and then plug the iPod into the display's FW port, as opposed to the 2nd FW port on your G5. The same thing happens to me if I've got an external hard drive connected and powered on, and I try to sync my iPod. Good luck.

  5. Sun Baked macrumors G5

    Sun Baked

    May 19, 2002
    Which FW ports, there is some problems that have been showing up for people on the front FW port requiring replacement of that panel.

    Otherwise all the FW ports are on the same bus and share the same 15W power supply (aka, from the same FW PHY Chip).

    So the problems are likely.

    1. Front panel cable.
    2. Front panel.
    3. Logic board.
  6. letterbox thread starter macrumors regular

    Apr 13, 2004
    I got it to work, but still would like some more insight into the problem.

    I do have 10.3.4

    I repair permissions every week or so and I leave it on at night to run crons

    The iPod was not showing in SP

    I disconnected all FW devices (incl. monitor) and then tried the iPod in the front and it didn't work, then I tried it in the back and it worked, then I tried it in the front and it worked then I plugged in monitor and plugged the iPod into that and it now works.

    It was odd because the iPod would be charging, but wouldn't mount. Once it even said "Do not disconnect" on the iPod screen, but wouldn't mount on the HD or in iTunes.

Share This Page