FYI: Failed boot of Knoppix DVD required SMC reset on MBA to revive USB port

Discussion in 'MacBook Air' started by Frazzle, Feb 9, 2010.

  1. Frazzle macrumors regular

    Mar 1, 2007
    Hello, I just had a weird experience with my MBA (2,1 with SSD).

    I had hooked up the MBA SuperDrive and wanted to see, just for fun, whether the machine could boot from a Knoppix DVD. (Knoppix is a Linux distribution that can run straight off the DVD without touching the harddisk.)

    I tried and it seemed to work fine, until I got stuck on a blank screen. Oh well.

    I switched off the MBA by holding the power button for >4 secs and it shut down. Rebooted, and noticed that the SuperDrive didn't make any noise. Once in OS X, I didn't get an icon for the DVD. Hmm. Hitting 'eject' didn't do anything.

    Checked out the System Profiler, no mention of a SuperDrive! :confused:

    Took out the SD, popped in a USB pendrive. Nothing! :eek:

    Had I fried my USB port? Sigh. I could already see myself carrying the MBA in for service. Until I remembered the 'Mac cure for everything': resetting the SMC. Did that, and lo and behold: my USB port came back to life. Everything worked again and I could eject the DVD no problem.

    I'm just posting it here for the benefit of other users. Has anyone experienced something like it?

Share This Page