GarageBand Jam Pack Update 1.01 won't install (OS X 10.5)

Discussion in 'Mac Apps and Mac App Store' started by badcrumble, Oct 26, 2007.

  1. badcrumble macrumors regular

    Joined:
    Feb 7, 2007
    #1
    It only showed up after installing Leopard. Can I make my computer think that I've already installed an update when I haven't really? It keeps trying to update one of my GarageBand JamPacks to version 1.01, but then says

    "The Installer could not install some files in “/”. Contact the software manufacturer for assistance."

    I don't want that update showing up in Software Update for the rest of my life.


    From the Console when trying to install the package:

    10/27/07 1:27:06 AM Software Update[212] *** -[NSLock dealloc]: lock (<NSLock: 0x184e9690> '(null)') deallocated while still in use
    10/27/07 1:27:06 AM Software Update[212] *** Break on _NSLockError() to debug.
     
  2. John Wayne macrumors newbie

    Joined:
    Oct 28, 2007
    #2
    i'm getting the same error with many other software.

    for example Skype and ikeys; they worked well and then the error appeared, and never worked again.
     
  3. Jade Cambell macrumors 6502

    Joined:
    Sep 14, 2007
    #3
    Yeah, a friend of mine got the same error. I didn't get the error though...
     
  4. John Wayne macrumors newbie

    Joined:
    Oct 28, 2007
    #4
    Alright boys and girls

    i figured it out, --- for my problem anyway.

    you simply need to delete the corresponding preference files

    YOU/Library/Preferences/com.*.plist

    like many, i installed leopard and then copied over my old home folder; this action also copied the old preference files corresponding to the old setup. These files needs to be reinitialized to the new config.

    hope this works out for you.
     
  5. dcp1970 macrumors newbie

    Joined:
    Jan 3, 2008
    #5
  6. BallsDeep83 macrumors newbie

    Joined:
    Aug 18, 2008
    #6
    Downloading from the link above and installing manually worked! Thank for the help man.
     

Share This Page