Get spinning beach ball as soon as I open Safari

Discussion in 'OS X Yosemite (10.10)' started by melburstein, Oct 12, 2014.

  1. melburstein macrumors regular

    melburstein

    Joined:
    Jul 3, 2012
    #1
    I've already reported this to Apple via the Feedback Assistance, but want to ask if anyone else is experiencing this problem. It started for me about one week ago and renders Safari unusable, forcing me to use Chrome.
     
  2. ErikGrim macrumors 68040

    ErikGrim

    Joined:
    Jun 20, 2003
    Location:
    Brisbane, Australia
    #2
    Are you using GlimmerBlocker by any chance?

    I had this, and I removed it and nuked my Safari folder. Been working fine ever since then.
     
  3. melburstein thread starter macrumors regular

    melburstein

    Joined:
    Jul 3, 2012
    #3
    No. But thanks for the reply.
     
  4. colourfastt macrumors 6502a

    colourfastt

    Joined:
    Apr 7, 2009
    #4
    I've been having this problem since PB1. Like the recurring junk mail problem with Mail, I've sent numerous "feedbacks" but haven't seen it resolved yet.
     
  5. ErikGrim macrumors 68040

    ErikGrim

    Joined:
    Jun 20, 2003
    Location:
    Brisbane, Australia
    #5
    Try removing the Safari folder from your library using this terminal command:

    mv ~/Library/Safari ~/Library/Safari.old

    (Don't worry, all your settings will be backed up should this not be the solution)
     
  6. melburstein thread starter macrumors regular

    melburstein

    Joined:
    Jul 3, 2012
    #6
    Problem solved. Thank you so much ErikGrim :). The terminal command could not find the file, so I used MuCommander to find and rename it.
     
  7. ErikGrim macrumors 68040

    ErikGrim

    Joined:
    Jun 20, 2003
    Location:
    Brisbane, Australia
    #7
    Glad to be of help :)
     
  8. tenebra87 macrumors newbie

    Joined:
    Oct 19, 2014
    #8
    Thanks Thanks Thanks a lot from Italy!!
    You saved me!

    Luca
     
  9. iMacUnsure macrumors member

    iMacUnsure

    Joined:
    Aug 24, 2013
    Location:
    Southern US
    #9
    I am having the same problem.Terminal could not find file. Where is mucommander?
     
  10. melburstein thread starter macrumors regular

    melburstein

    Joined:
    Jul 3, 2012
    #10
    mucommander is on the app store. Actually, you can just use Finder or the Terminal command.
     
  11. thebro20 macrumors regular

    Joined:
    Sep 7, 2014
    #11
    spinning beachball in safari

    Since a few days ago I'm constantly getting the spinning beach ball in safari. Just clicking on a link, typing something into a search bar or password, i get the spinning beachball. any ideas on what to do? I've never had this problem before.
     
  12. NJFP macrumors 6502

    Joined:
    Feb 18, 2009
    #12
    Its an issue in 10.10.1. Mine does it as well.
     
  13. MonkeySee.... macrumors 68040

    MonkeySee....

    Joined:
    Sep 24, 2010
    Location:
    UK
    #13
    Do you know where the backed up settings would be?

    Cheers
     
  14. ErikGrim macrumors 68040

    ErikGrim

    Joined:
    Jun 20, 2003
    Location:
    Brisbane, Australia
    #14
    In the Safari.old folder. Just rename it back.
     
  15. MonkeySee.... macrumors 68040

    MonkeySee....

    Joined:
    Sep 24, 2010
    Location:
    UK
    #15
    Thanks for the reply on this old thread. Its really appreciated
     
  16. markrdavis macrumors newbie

    Joined:
    Oct 12, 2015
    #16
    OK. Bit of a newbie here. How do I find that file, rename and get my settings back. I've just lost a LOT of good bookmarks!

    Thanks
     
  17. MonkeySee.... macrumors 68040

    MonkeySee....

    Joined:
    Sep 24, 2010
    Location:
    UK
    #17
    Might be on your desktop
     
  18. patrickwlee macrumors newbie

    Joined:
    Oct 31, 2015
    #18
    I found a solution to this, if you are using Click to Plugin, or Adblocker extensions in Safari, in Safari preferences, Advanced Tab, uncheck "Stop plug-ins to save power".
     
  19. Gjwilly macrumors 68030

    Joined:
    May 1, 2011
    Location:
    SF Bay Area
    #19
    This solved my problem so I just had to bump it to show that it's still relevant.
    I've got the latest El Capitan beta and the beach balls have only been getting worse and worse.
    If you log out of iCloud before performing the step above and then log back in to iCloud after, you won't even lose any bookmarks (provided you use iCloud to sync your bookmarks).
    Mucho thanks.
     

Share This Page