Getting an old 3GS to iOS 5.1.1?

Discussion in 'iPhone' started by joelshooty, Sep 23, 2012.

  1. joelshooty macrumors member

    Joined:
    Dec 19, 2007
    #1
    I have an iPhone 3GS running iOS 4.0.1. It has never been jailbroken.

    Is it possible to get this phone up to iOS 5.1.1 (and then jailbreak, if I decide to)?

    It looks like Apple has stopped signing 5.1.1, so I'm thinking that I'm out of luck, but I thought I'd ask the MacRumors experts before throwing in the towel.
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    You can only update to iOS 5.1.1 if you have your SHSH blobs for 5.1.1. If you don't you cannot. Unless your 3Gs is an old bootrom 3Gs, then you don't need signed SHSH blobs. Use Google to find you how to check your 3Gs' bootrom version.
     
  3. joelshooty thread starter macrumors member

    Joined:
    Dec 19, 2007
    #3
    Thanks for the quick reply. I have the new bootrom and I do not have SHSH blobs, so I guess I can't get to 5.1.1.
     
  4. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    That is correct. In that case, you can only put iOS 4.1 (because for some reason Apple is still signing this for the 3Gs and iPT 3) or iOS 6.0 onto your iPhone 3Gs.
     

Share This Page