Gmail Push Email PROBLEM

nanogirl21

macrumors 6502a
Original poster
Sep 20, 2011
698
63
Midwest United States
Has anyone recently had any problems pushing their gmail to their 4s devices? I am set up via exchange and am not getting any emails pushed. I tried to switch from push to fetch. And I have tried manual mode but it still didnt work. I have messed with all the options and I am pretty sure they are set up correctly. I restarted my phone too. I am on 5.0.1. I was getting emails without any problems before today. I would prefer to have my mail pushed and not have to go to google.com every time I want to check my mail. I also tried adding my account information from the exchange section to regular gmail but no luck. Help please.

Email = my email
Server = m.google.com
Domain = m.google.com
Username = my email again
Password = my password
Use SSL = on
S/MIME = off
 

Yoda3984

macrumors member
Mar 12, 2008
63
2
Arkansas
I've been having this issue intermittently for both of my Gmail accounts (set up as Exchange) since installing iOS 5.1. That seems oddly coincidental, but it could just be a Google problem.
 

qtaran111

macrumors member
Jun 15, 2010
95
0
Mine is working fine. Here's some things to check:

First of all make sure you have Push set correctly:

Settings > Mail, Contacts, Calendars > Fetch New Data > Push "On"

Now still in Fetch New Data go Advanced > Gmail (or whatever you have called your Gmail account) > and under Select Schedule, select "Push".

I have nothing entered into the Domain setting (rather than m.google.com). Not sure if this makes a difference, but as I said, mine works. ;)