Google Maps mobile site in Safari no longer has permission to access location?

Discussion in 'iOS 6' started by avanpelt, Nov 16, 2012.

  1. avanpelt, Nov 16, 2012
    Last edited: Nov 16, 2012

    avanpelt macrumors 68030

    Jun 2, 2010
    I have cleared history, cache, website data, and turned Location Services for Safari off and back on. I also rebooted the phone. I'm running iOS 6.0.1.

    When I go to in Safari, it still says "Google Maps does not have permission to use your location." Other websites still prompt me for my location, but Google Maps just says it doesn't have permission. If I tap the locate icon, it prompts me with the same error.

    Anyone else seeing this? Could Apple have purposely disabled location services just for the Google Maps mobile site?
  2. Dolorian macrumors 65816


    Apr 25, 2007
    Would be odd considering that Cook recommended this to his users in the apology he published not long ago.

    Edit: I tested it on my iPhone 4 and it worked fine, asked for my location and when I hit Ok it worked.

    My IP4 has iOS 6.0.
  3. avanpelt thread starter macrumors 68030

    Jun 2, 2010
    Here's what I'm seeing. Note that the location services arrow appears up top but it still says Google Maps doesn't have permission.

    Attached Files:

  4. intrepid00 macrumors 6502

    Sep 28, 2008
    Your settings got corrupted, happened to me.

    Settings > General > Reset > Reset Location & Privacy
  5. avanpelt thread starter macrumors 68030

    Jun 2, 2010
    Bingo! That solved it. Thank you!!

Share This Page