Had to restore phone, now sms and phone not working on Mac

Discussion in 'iPhone' started by lwilliams, Dec 30, 2014.

  1. lwilliams, Dec 30, 2014
    Last edited: Dec 30, 2014

    lwilliams macrumors 6502


    Nov 27, 2012
    Athens, GA
    I had to do a restore (as a new phone) of my i6+ today because of email problem.

    MacBook running 10.10.2. After the restore, I can't send text to people form my Mac that are not iMessage people.........and the phone ringing does not show on the Mac.

    All work perfectly before this. What do I need to do?
  2. rigormortis macrumors 68000


    Jun 11, 2009
    try turning off handoff on all your computers and iOS devices and on again
    make sure they are all signed on to iCloud

    as far as iMessage and facetime go, are those features activated?

    when i replaced my brothers iPhone recently , it took 6 hours for facetime and iMessage to come back. we called applecare and they had no real explanation, they told us to call the carrier. and the carrier was like , what gives

    go to facetime and message settings and make sure that it does not say "waiting for authorization"

    you probably need to pair the iMessage and mac again, sometimes the macs over here seem to take forever to recognize the iPhone was sending it a pin to pair them

    basically just turn off handoff on everything and turn it back on everything and cross your fingers
  3. lwilliams thread starter macrumors 6502


    Nov 27, 2012
    Athens, GA
    Spent over an hour with an Apple Tech and got nowhere.

    Later, spent 3 minutes with another Apple Tech and it is fixed.

    Got to Setting ----> Messages...... second option is "Text Message Forwarding". That is OFF by default. Turned it on, selected my MacBook. Backed out and everything works perfectly.

    Now, I have never turned this on before and it all worked with the iPhone 5, then with the iPhone 6, and then the iPhone 6+.

    I did the restore on the 6+ because of an email problem. Apple says that settings is always off by default. But for me, it was on by default until the restore.

    Anyway, it did take TWO Apple techs to find the problem. First one never even mentioned this setting. That makes me wonder......

    At least I know now .........

Share This Page