OS X Halo 2.0.4 - Slow on Mavs and no online games?

Discussion in 'Mac and PC Games' started by cosmichobo, Jun 8, 2014.

  1. cosmichobo macrumors 6502

    cosmichobo

    Joined:
    May 4, 2006
    #1
    G'day,

    I've just recently upgraded from a PowerMac G5 to a 24" 2.93GHz iMac C2D, and have found that Halo is now unplayable - no matter what settings I use, gameplay is like walking through treacle with frames dropping every second.

    Further, I noticed on the GameSpy online servers page, although maybe a few dozen servers appeared, there was only 2 with people playing - and only 1-2 people at that...

    Reading up, I see that Mavericks has been causing issues for Halo..? And also that GameSpy is no longer supporting Halo...

    I've found the unofficial mod for 2.0.4... about to test it out... but - there's little point if I can't join an online game..!

    Has there been any talk of a fix for the Mac version RE online servers (as I see there is one for the PC version)..

    cheers,
    cosmic
     
  2. cosmichobo thread starter macrumors 6502

    cosmichobo

    Joined:
    May 4, 2006
    #2
    Nevermind - found the Halo UB patch - all good!!!
     
  3. ScottishCaptain macrumors 6502a

    Joined:
    Oct 4, 2008
    #3
    How the hell did you get the Halo PowerPC binary running on Mavericks?

    Rosetta was dropped in 10.7?

    -SC
     
  4. cosmichobo thread starter macrumors 6502

    cosmichobo

    Joined:
    May 4, 2006
    #4
    Well Scottish Captain, you see, I'm a bloody genius!

    First, I dismantled and desoldered the CPUs from my G5, then I made a new board for them and installed onto the iMac via the ethernet port. Who needs it - everything's wireless these days.

    Then, I de-compiled OS 10.9 and added in a hack to address the old chips as part of the booting subroutine. Totally against the EULA of course...

    Oh what - no - I didn't do any of that, I was just using the UNIVERSAL BINARY of Halo...
     
  5. ScottishCaptain macrumors 6502a

    Joined:
    Oct 4, 2008
    #5
    I quote:

    Followed by:

    This makes me think that you transferred your applications from your G5 directly to the iMac, and somehow you'd gotten Halo to run... Just not well, until you applied the UB patch.

    Since Mavericks doesn't support PowerPC binaries, either you weren't running Mavericks, or you weren't running the latest version of Halo (which was still a universal binary, because otherwise it wouldn't run under Mavericks at all). Either way it sounded like you had somehow gotten Rosetta to run under 10.9 or something.

    -SC
     
  6. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #6
    I'm confused too. If you didn't already have the Halo UA then you shouldn't have been able to run it at all :confused:
     
  7. cosmichobo thread starter macrumors 6502

    cosmichobo

    Joined:
    May 4, 2006
    #7
    Sorry for any confusion.

    Allow me to elucidate.

    Many years ago, I purchased an eMac G4 PPC from Apple. Darn fine machine except for that whole bad caps thing, but I paid Apple back by spending 2 years sitting on their Discussion forum, telling every eMac owner to take advantage of Apple's Repair Program (once they finally announced it).

    Having been a Mac boy from way back, I of course promptly installed Halo - the PPC version. And it worked pretty well, all things considered, for a 1.25GHz machine made for the education market!

    But time dragged on, and the eMac started to fall behind. Being however as I was, a very poor member of the lower socio-economic branch of life, I had little upgrade options, until one day I came across a dual 1.8GHz G5 PowerMac for a mere $99 at a pawn shop. Big mistake, of course, but I took a leap of faith...

    Still PowerPC of course, and still limited to OS 10.5.8, I simply used the PPC verison of Halo on this "new" machine too... until one day I noticed the lack of other users, and started investigating... to discover there was a Universal Binary version of the game. So I gave that a go, to discover it played a bit better, and had more online players.

    Finally just earlier this year I found enough cash to buy a 4 year old Intel iMac. It came with 10.8, but as Mavericks was free, I upgraded to 10.9.1. And I installed Halo Universal Binary.

    But it played terribly! Very odd, I thought, as surely the Early 2009 iMac was better than the June 2004 PowerMac???

    So I started to google, and post questions on forums where kind people are generous enough to help where they can. Soon I learned of the unofficial patch that was aimed to allow multiplayer to continue to operate, but as a side effect, had been known to resolve an issue that made some users experience a situation where the game would either not open at all, or would run terribly slowly.

    Viola! Problem solved!

    Yay!
     

Share This Page