Halp? Gevey unlocked iPhone4 works with 4.3.5 but can't upgrade or downgrade

Discussion in 'Jailbreaks and iOS Hacks' started by gswearengin, Nov 18, 2011.

  1. gswearengin macrumors newbie

    Joined:
    Oct 1, 2007
    #1
    Hey y'all,

    I recently got an iPhone4 with iOS 4.3.5 and the 04.10.01 baseband. I've now got it jailbroken on 4.3.5 and I'm using a Gevey SIM for the unlock. The good news is that everything works. The bad news is that I'm stuck. I keep trying to reinstall other IPSW's but the installation fails with the "This device is not eligible for the current build" error.

    My ultimate goal is to either get the phone back to the stock 4.3.5 firmware (untethered) or maybe update to iOS5 without updating my baseband. I don't care about a jailbreak, I just need the unlock. I keep trying every proposed solution I can get my hands on, but nothing works and I am getting really frustrated.

    Anybody got any suggestions for what the problem might be? Any help appreciated.

    Thanks,

    GS
     
  2. kvizzel macrumors 6502a

    Joined:
    Jan 15, 2011
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_3 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8J2 Safari/6533.18.5)

    You are probably downloading the wrong iOS for device. The only thing you can do is up to 5.01 create your own custom firmware off redsn0w or sn0wbreeze and install it. It's simple google for guides.
    Unless you have blobs saved, go to cydia and check if you have any saved. Should say at the top.
     
  3. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #3
    You can't downgrade (go back to 4.3.5) without blobs. Unless you see blobs in cydia, you can't do it.
    You'll need redsnow or snowbreeze to preserve the bb because you have to upgrade.
    I don't understand why you felt it necessary to install a different iOS in the first place.
     
  4. gswearengin thread starter macrumors newbie

    Joined:
    Oct 1, 2007
    #4
    I hadn't quite done enough research at the time I got the phone. I had to jailbreak because I was sold a fake Gevey SIM from what claimed to be a reputable source (I'm in Europe, so it's not as simple as just buying from applenberry.com). Once I got my hands on a real Gevey, I could have just used the version of iOS that was on the phone when I got it. D'oh.

    Okay, so I can't downgrade. No big deal. But what about either un-jailbreaking (to get rid of the tethered boot) or upgrading to 5.0(.1?) while preserving my baseband? I have .ipsw's for both, but get the same error (the device isn't eligible for the requested build) when I try to install them. Any tips or suggestions?

    Thanks,

    GS
     
  5. cruzer-u3 macrumors member

    Joined:
    Nov 16, 2011
    #5
    you have to edit hosts file to restore & you can only restore to 5.0.1 no 5.0
     
  6. gswearengin thread starter macrumors newbie

    Joined:
    Oct 1, 2007
    #6
    Thanks again for the tips. I have tried lots of different options with the host file. Since I am not trying to jailbreak, I am assuming I want to remove the Cydia entries to gs.apple.com, correct? That leaves the hosts file pretty much empty, except for the loopback entries. Is that how it ought to be?

    I'm pretty sure I've tried this before and still got the "device not eligible..." error, but will happily try again. :) Could this work for 4.3.5, as well?

    Thanks,

    GS
     

Share This Page