Handbrake can't seem to handle newer movies.

Discussion in 'macOS' started by Zack512, Jul 24, 2008.

  1. Zack512 macrumors newbie

    Joined:
    Jul 22, 2008
    #1
    I tried to rip a backup of a movie I recently bought (Semi-Pro), and for some reason MTR could not finish without the disk stopping. It just kept spinning, then stopping and trying again for a long while. So I figured I would just use handbrake and copy a MP4 to my computer, so I wouldn't have to use the disk every time I wanted to watch the movie. However, when the encoding process starts, It goes for about 30 sec. and says that the movie is complete. When I click on the MP4 it plays about 10 sec. of the intro and thats all there is. What is going on? MTR, and handbrake seem to work fine for me on other movies. Is it because it is a newer movie, and they added something that these programs can't handle? I noticed the first time I tried to rip it with MTR it popped up a message saying that there were "intentional dummy Video TS files", but now it doesn't even do that it just freezes. Any suggestions?:confused:
     
  2. sickmacdoc macrumors 68020

    sickmacdoc

    Joined:
    Jun 14, 2008
    Location:
    New Hampshire
    #2
    I guess the first question to ask is what version of Mac The Ripper are you using? If it is the freeware version 2.66 that one is very old and not able to deal successfully with modern protection schemes.

    The current (and only supported) version of MTR is 3.0 r14m which handles MANY more movies. To get it, go to www.ripdifferent.com and join the Mac The Ripper forums. Then read the sticky notes as to the correct method to send a "gift" to the developer to obtain the current and future versions.
     
  3. ltldrummerboy macrumors 68000

    ltldrummerboy

    Joined:
    Oct 15, 2007
    #3
    Are you using Tiger? I had problems with Ratatouille but the latest (Leopard only) version of Handbrake made everything work.
     

Share This Page